beantwoord

Eigen modem + tv

  • 28 maart 2020
  • 30 reacties
  • 1382 keer bekeken

Reputatie 1

Ik kon spontaan niet meer terugkijken op mijn tv ontvanger. Heb de ontvanger gerestart (zonder succes), en heb vervolgens opnieuw de software opgehaald. Nu doet de hele ontvanger niets meer. Krijg foutcode 561. Met de vorige update van jullie had ik ook al problemen met de tv ontvanger. Toen bleek het zo te zijn dat de IPTV ineens ook gerouteerd moest worden. Ik maak gebruik van een edgerouter lite als modem omdat ik in het verleden alleen maar problemen heb gehad met de experiabox. Heb echt geen idee wat er mis is aangezien ik aan mijn kant niets heb aangepast en dit probleem van de een op de andere dag is ontstaan.

Bij voorbaat dank voor de hulp!

groet Rik

icon

Beste antwoord door Rikkerdt 30 maart 2020, 21:03

Ik heb de setup voor mijn edgrouter lite 3 (glasvezelverbinding) uiteindelijk werkend gekregen door eerst de configuratie zonder voip te downloaden van de kpn website (https://forum.kpn.com/thuisnetwerk-72/gebruik-een-eigen-router-i-p-v-de-experia-box-458609). In deze configuratie staat de IPTV al correct ingesteld. Vervolgens via “add interface” vlan 34 aangemaakt op de WAN interface en een nat rule aangemaakt met het netwerkadres van mijn lan interface als source & een masquerade naar ethernet 0.34.
 

Vervolgens via de CLI :

configure

set interfaces ethernet eth0 vif 34 mac xx:xx:xx:xx:xx:xx

commit
save
exit

vul het mac adres dat achterop je experiabox staat in op de plaats van de kruisjes. Ik weet niet of dit specifieke mac adres een noodzakelijke stap is, maar het was bij mij essentieel.

Ten slotte:

configure

set protocols igmp-proxy interface eth0.4 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth0.4 role upstream
set protocols igmp-proxy interface eth0.4 threshold 1
set protocols igmp-proxy interface eth1 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth1 role downstream
set protocols igmp-proxy interface eth1 threshold 1

commit
save
exit
Bekijk reactie

30 reacties

Internet zelf werkt wel? Werkt live tv kijken? Heb je een dsl of glasvezel verbinding?

Reputatie 1

@Galdor68 Internet werkt. Heb een glasvezelverbinding. Tv kijken werkte eerst wel maar daarna niet meer. Situatie: Ik word wakker en wil een programma terugkijken dat ik gisteren heb opgenomen. Live TV kijken werkt. Ik klik op de opname via het menu en krijg error 3025. Ik kijk op de site of er een storing is. Dat is niet het geval dus ik haal opnieuw de software op. Nadat ik de software opnieuw heb opgehaald werkt niets meer en krijg ik foutcode 561.

 

Reputatie 8

Ik vermoed dat je de Edge router niet goed hebt geconfigureerd om IPTV in “routed mode” in te zetten. KPN/Telfort is in een paar tussenstappen overgegaan naar een volledige “routed mode”.

Zelf heb ik dat al eerder gemerkt, maar diverse gebruikers merken het pas nu met de laatste TV-ontvanger firmware updates. Zie eerder draadje, en gerelateerd de instellingen die nodig zijn, nu met “vrije router keuze” voor in ieder geval KPN.

https://forum.telfort.nl/tv-338/firmware-7-3-83-5-kpn-telfort-tv-ontvangers-beperkt-gebruik-eigen-routers-85277

https://www.kpn.com/service/internet/wifi-en-modems/eigen-modem-instellen-en-gebruiken.htm

Voor een Ubiquity Edge router zijn er overigens wel werkende set-ups:
http://wvthoog.nl/telfort-fiber-iptv-dutch/

Reputatie 1

@Babylonia Ik zal vannacht even de setup van wvthoog.nl proberen na te bootsen in mijn eigen netwerk. Alvast bedankt voor de reactie :)

Reputatie 8

Mocht je er nog niet zijn uitgekomen.
Bij KPN staan ook configuratiebestanden ter download:

https://forum.kpn.com/thuisnetwerk-72/gebruik-een-eigen-router-i-p-v-de-experia-box-458609

Dat is dan wel voor de situatie bij “KPN”. Die is iets afwijkend tegenover Telfort.
Voor TV is dat vergelijkbaar (VLAN 4).
Voor internet geldt voor KPN VLAN 6, voor Telfort VLAN 34
KPN heeft verder een PPPoE aanmelding voor internet,
Telfort zonder aparte inloggegevens, automatisch IP verkrijgen vanuit DHCP.

Reputatie 1

Ik zie in het document van wvthoog het volgende staan. ik begrijp dat ik het router ip dat voor mij van toepassing is moet invullen bij 'router_ip_address’, klopt het ip address ( 213.75.112.0) wel?

 

Citaat: set protocols static route 213.75.112.0/21 next-hop router_ip_adres

Reputatie 1

Oke, op dit moment heb ik de live tv weer werkend gekregen door hem eerst de configuratie op te laten halen via de experiabox. Ik heb de configuratie voor de edgerouter nagemaakt zot zoals aangegeven op wvthoog.nl Echter kan ik nog steeds geen opgenomen programma's terugkijken (error 3025).

 

Edit: ik heb nu het configuratiebestand van kpn op mijn edgerouter geflasht. Verder niets aangepast. Internet werkt niet meer maar heb nu wel weer volledig werkende tv??

Reputatie 8

Edit: ik heb nu het configuratiebestand van kpn op mijn edgerouter geflasht. Verder niets aangepast. Internet werkt niet meer maar heb nu wel weer volledig werkende tv??

TV-streams zijn zoals eerder aangehaald voor KPN en Telfort hetzelfde. (Voor beide VLAN 4)
Evenwel internet is voor KPN net iets afwijkend tegenover Telfort. Vandaar dat dat stukje niet werkt.
Dus je zult dan net even de set-up moeten aanpassen voor wat betreft “internet” voor Telfort.

Welk bestand heb je bij KPN gedownload?

Mogelijk kun je de configuratie van “wvthoog.nl” vergelijken met welke je hebt gedownload bij KPN.
Dan het stukje wat geldig is voor “internet” voor Telfort vanuit de configuratie van “wvthoog.nl”,
kopiëren en plakken binnen het stuk van het configuratiebestand van KPN.

Dat aangepaste configuratiebestand dan inladen in de Edgerouter.

Overigens zie ik in de beschrijving bij "“wvthoog.nl”

      “Bovengenoemde MAC adres heb ik overgenomen van de originele Telfort router.
       De jouwe zal anders zijn.

Het gebruik van een specifiek MAC-adres vind ik vreemd. Omdat wel- of geen connectie ervan niet afhangt van een MAC-adres. (Ik heb hier 6 verschillende routers met evenzoveel verschillende MAC-adressen waar ik een connectie mee kan leggen).

 

klopt het ip address ( 213.75.112.0) wel?

Citaat: set protocols static route 213.75.112.0/21 next-hop router_ip_adres

Als ik die waarden vergelijk in de Experia Box V8, lijkt het uit een pool te komen voor DNS server adressen. Die beginnen met 213.75…..

Maar geenszins WAN IP-adressen die bij KPN / Telfort worden toegepast.
(Die zouden gewoon vanuit DHCP automatisch moeten worden uitgegeven).

Als het om DNS-servers gaat lijkt me dat je die beter handmatig kunt instellen in het menu van de Edgerouter? En dan niet de DNS-servers gebruiken van KPN / Telfort, maar van Google of bijv. Cloudflare.

8.8.8.8   -    8.8.4.4  =  Google
1.1.1.1   -    1.0.0.1   =  Cloudflare

Reputatie 1

@Babylonia dank voor de reactie. Ik heb de edgerouter lite 3 zonder voip configuratie.(https://forum.kpn.com/thuisnetwerk-72/gebruik-een-eigen-router-i-p-v-de-experia-box-458609)

Ik ben momenteel bezig met het vergelijken van de setup van wvthoog.nl alleen daar word gebruikt gemaakt van de wan2lan2 functie. Wat houd deze functie exact in? Ik heb het geprobeerd aan te klikken alleen dit reset het hele systeem

Reputatie 8

Zelf heb ik geen Edgerouter. Heb ook geen vergelijk met een interface / menu’s etc.
Dus het gaat mij eigenlijk wat te ver om er uitspraken over te kunnen doen waar de ene- of andere beschrijving betrekking op heeft. Misschien zou je zelf contact kunnen leggen met de persoon die de beschrijving op  "wvthoog.nl ”heeft geschreven. Zit je het dichtst bij het vuur.

Nog even terugkomend op die IP-adressen eerder door je genoemd,
waaronder   213.75.112.0
Die zou mogelijk toch ergens in de configuratie opgenomen moeten worden ??

Als ik de Experia Box V8 hier terug hang en in de routing tabel kijk, kom ik die daarin tegen.
Van onderstaande afbeelding, zie rood omkaderd IP-adres. Mogelijk betrekking op IPTV ??

-- De blauw omkaderde IP-adressen hebben betrekking op  IPTV
-- De gedeeltelijk afgeschermde IP-adressen betreffen mogelijk de Gateway e.d. bij Telfort
    waar mijn WAN IP-adres aan is gerelateerd, (vandaar dat ik die heb afgeschermd).

 

Reputatie 1

Enkele uren verder en het is me gelukt om op zowel internet als iptv de verbiding te laten werken. Alleen niet tegelijkertijd. Enig idee wat dit probleem veroorzaakt? Als ik eth 0.34 disable krijgt vlan0.4 een ip & vice versa. (Dank voor de routing table + uitleg. Het heeft me erg geholpen)

Reputatie 1

Ik weet niet wat bovenstaand probleem veroorzaakt, maar zodra ik het mac adres van mijn experiabox spoof op eth0.34 werkt zowel iptv als internet tegelijkertijd.:thinking:  (dank aan http://robswinkels.nl/2017/03/05/ubiquiti-edgerouter-lite-configured-with-telfort-sni-f/).
Het lijkt haast wel alsof het gebruiken van de experiabox geforceerd word.

Reputatie 8

Het spoofen van het MAC-adres is naar ik denk een “omweg” in de set-up?  (Bijv. in de set-ups voor een Fritzbox router met KPN of Telfort profiel, is het niet nodig een extra MAC-adres te spoofen).

M.b.t. je eerdere opmerking / reactie:

Enkele uren verder en het is me gelukt om op zowel internet als iptv de verbiding te laten werken. Alleen niet tegelijkertijd. Enig idee wat dit probleem veroorzaakt? Als ik eth 0.34 disable krijgt vlan0.4 een ip & vice versa. (Dank voor de routing table + uitleg. Het heeft me erg geholpen)

Normaal gezien kan een router slechts één IP-adres aanvragen voor een WAN-poort voor “internet”.
Achterliggend moet er echter tevens in een ander VLAN voor IPTV ook een IP-adres worden aangevraagd. Dus twee verschillende IP-adressen in verschillende sub-net bereiken.

Als de code niet goed is opgezet, worden er na een eerste IP-adres aanvraag, welke door de server bij KPN wordt gehonoreerd dan geen vervolg IP-adressen meer afgegeven. Ofwel:

Wordt als eerste een “internet” IP-adres opgevraagd, dan niet meer een IP-adres voor IPTV.
En vice versa.
Wordt als eerste een “IPTV” IP-adres opgevraagd, dan niet meer een IP-adres voor internet.

Als ik de uitgebreide informatie bij KPN teruglees die nu met het vrije modem-beleid online is gezet, zou het kunnen zitten in de volgende commando’s:

Wat zijn de instellingen voor de routed mode televisie?

De router functioneert in dit geval als laatste apparaat vanuit het TV-platform, daarom moet je IGMP proxy inschakelen (IGMPv2). Daarnaast moet je op de router (en eventuele switches), tussen de router en de TV-ontvanger, IGMP snooping inschakelen. Dit zorgt ervoor dat het multicast TV-verkeer alleen op de poorten van de switch wordt aangeboden, waarop de televisie is aangesloten. IGMP fast leave is noodzakelijk om onnodige streams, bijvoorbeeld het proces van schakelen van zender naar zender, af te sluiten.

Voeg eveneens bij de DHCP Option 60 (Vendor Class Identifier), de string: IPTV_RG (ASCII karakter) toe (dit is nodig voor een goede communicatie met de TV-ontvanger). Daarnaast moet je optie 121 (Classless Static Route Option) [RFC3442] toepassen.

Kijk ik bijv. bij “netwerkje.com”  wordt ook daar extra nadruk op gelegd:

option 60: IPTV_RG

Stuur je deze option niet mee, dan krijg je geen IP adres terug. De DHCP server van KPN blijft dan compleet stil. Ondersteunt je router dit niet, dan kun je dus geen gebruik maken van routed IPTV.

In ieder geval heb je het zaakje nu werkend. :thumbsup:
Kun je (zo mogelijk) beknopt weergeven welke basis-configuratie je hebt gebruikt,
en wat je als extra hebt toegevoegd, of afwijkend hebt ingesteld met de achterliggende configuraties met wat je hebt gevonden op de websites van o.a:

-- KPN - uitgebreide informatie voor gebruik eigen modem/router
-- De persoonlijke pagina’s bij “netwerkje.com”
-- De persoonlijke pagina’s van ”W v't Hoog”
-- De persoonlijke pagina’s van "Rob Smulders”  (met verwijzing naar "kriegsman.io” ).

Reputatie 8

Nog even terugkomend op:

Ik weet niet wat bovenstaand probleem veroorzaakt, maar zodra ik het mac adres van mijn experiabox spoof op eth0.34 werkt zowel iptv als internet tegelijkertijd.:thinking: 

en:

Het spoofen van het MAC-adres is naar ik denk een “omweg” in de set-up?  (Bijv. in de set-ups voor een Fritzbox router met KPN of Telfort profiel, is het niet nodig een extra MAC-adres te spoofen).

Omdat er feitelijk twee IP-adressen moeten worden uitgegeven, een voor internet, en een voor IPTV, moeten daar ook twee MAC-adressen tegenover staan als herkenning naar een “toegangspoort”.

Omdat een router normaal op een WAN-poort slechts één MAC-adres heeft, moet mogelijk voor dat extra IP-adres dat extra MAC-adres worden “gefingeerd”. Vandaar het softwarematig “bijschakelen” van dat MAC-adres. Door in de Edge router het MAC-adres in te vullen van een Experia Box, weet je in ieder geval zeker dat het niet op andere wijze in gebruik is (als alleen in die Experia Box, die dan in de kast staat). En het is beslist anders dan van de WAN-poort van de Edge router zelf.

Ter info. Op de statuspagina van een Experia Box V8 vind je ook verschillende MAC-adressen terug voor zowel het WAN IP-adres voor internet, als IPTV.

Voor LAN en WLAN is het hetzelfde MAC-adres.
Voor WAN-poort internet en VOIP is dat hetzelfde (beide gaat via VLAN 34)
En dus eentje nog apart voor IPTV (iTV)

Reputatie 1

Ik heb de setup voor mijn edgrouter lite 3 (glasvezelverbinding) uiteindelijk werkend gekregen door eerst de configuratie zonder voip te downloaden van de kpn website (https://forum.kpn.com/thuisnetwerk-72/gebruik-een-eigen-router-i-p-v-de-experia-box-458609). In deze configuratie staat de IPTV al correct ingesteld. Vervolgens via “add interface” vlan 34 aangemaakt op de WAN interface en een nat rule aangemaakt met het netwerkadres van mijn lan interface als source & een masquerade naar ethernet 0.34.
 

Vervolgens via de CLI :

configure

set interfaces ethernet eth0 vif 34 mac xx:xx:xx:xx:xx:xx

commit
save
exit

vul het mac adres dat achterop je experiabox staat in op de plaats van de kruisjes. Ik weet niet of dit specifieke mac adres een noodzakelijke stap is, maar het was bij mij essentieel.

Ten slotte:

configure

set protocols igmp-proxy interface eth0.4 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth0.4 role upstream
set protocols igmp-proxy interface eth0.4 threshold 1
set protocols igmp-proxy interface eth1 alt-subnet 0.0.0.0/0
set protocols igmp-proxy interface eth1 role downstream
set protocols igmp-proxy interface eth1 threshold 1

commit
save
exit
Reputatie 8

Dank voor de aanvullingen.

Vervolgens via de CLI :

vul het mac adres dat achterop je experiabox staat in op de plaats van de kruisjes. Ik weet niet of dit specifieke mac adres een noodzakelijke stap is, maar het was bij mij essentieel.

Naar ik vermoed wel als zijnde een “extra” MAC-adres zoals uitgelegd in mijn vorige reactie.
Maar of het perse het MAC-adres zou moeten zijn van de Experia Box betwijfel ik zelf ten zeerste.
Als het maar “anders” is dan die van de normale WAN-aansluiting van de Edge router.
Zelf denk ik dat elk willekeurig ander MAC-adres voldoet.

Reputatie 8
Badge +11

Hoi @Rikkerdt, je had een aardige puzzel met het eigen modem zo te zien. Gelukkig is het, met de hulp van Babylonia, inmiddels gelukt en klinkt het alsof alles nu werkt. Dat is fijn om te lezen!

Reputatie 1

Nou, we zijn iets meer dan 2 weken verder en raad eens? Mijn tv ontvanger stopt er weer spontaan mee! Ben er zo langzamerhand wel een beetje klaar mee..

Reputatie 1

Heeft 1-2 seconden beeld en geeft vervolgens de melding: Zender niet beschikbaar. TV heeft gewerkt sinds mijn laatste post en ik heb niets gewijzigd. Mis ik iets?

 

Reputatie 8

Lijkt er kennelijk toch een manco in je configuratie te zitten dat het om die reden niet goed loopt?
Of heb je iets in je thuis netwerksituatie veranderd waardoor een onvoorziene verstoring?

Reputatie 8

Ben er zo langzamerhand wel een beetje klaar mee..

Als het met een Edgerouter zo omslachtig lijkt te gaan, met telkens weer opnieuw verassingen.
Misschien eens denken aan een ander type router met minder frustraties?

Inmiddels gisteren bij een kennis een DrayTek router ingeregeld voor een KPN glasvezel account.
(Zou ook kunnen voor een VDSL koper-aansluiting). Compleet met routed mode IPTV.

Met wat kleine aanpassingen voor de instellingen ook in te zetten voor Telfort.
Voor meer info en hoe ingesteld zie de reactie die ik heb geschreven op het Synology forum

Reputatie 1

Ik zat er zelf aan te denk om over te stappen naar KPN, alleen aangezien telfort KPN word weet ik niet of dit nou wel zo zinvol is

Reputatie 8

Voor het gebruik van die Edgerouter maakt dat natuurlijk niks uit.
Er wordt van hetzelfde TV-platform gebruik gemaakt. Zelfs dezelfde VLAN 4 is actief voor IPTV.
Dus naar ik vermoed zul je precies dezelfde problemen tegenkomen.

Het enige verschil is gebruik van VLAN 6 voor internet en een PPPoE aanmelding.

Reputatie 1

Ik heb dus nog steeds niets gewijzigd aan mijn setup en nu werkt de tv spontaan weer:grin: enig idee wat dit zou kunnen veroorzaken?

Reputatie 8

Misschien niets aan set-up veranderd, maar merk je het probleem als mogelijk een bepaald apparaat in je netwerk is ingeschakeld of juist niet??

Bij de set-up met die DrayTek in het topic bij Synology, kwam ook even een haperende TV voorbij.
Bleek die kennis van mij ergens achterliggend nog een IP camera-recorder te hebben hangen, met een eigen sub-net met DHCP-server, die in hetzelfde bereik zat als waar hij de nieuwe DrayTek op had ingesteld. Netwerkkabel van achterliggende systeem eraf, en probleem was over.

Een oude DrayTek router, die hij eerst in een NAT achter NAT set-up had ingesteld achter de Experia Box was wel met een ander sub-net voorzien. Had hem eerder al meteen geadviseerd om een vergelijkbaar sub-net te gebruiken als met de oude DrayTek router, om voor zijn achterliggende systemen niet onverwachts tegen problemen aan te lopen. Het enige verschil nu is, dat de Experia Box die hij er eerst ook nog voor had zitten, er nu in ieder geval tussenuit is.
(De rest van een beter ingericht systeem voor zijn IP-camera’s, en IoT apparaten komt later wel).

Misschien heb je iets vergelijkbaars in je set-up, of brengt het je op een idee?

Reageer