Werkend glasvezelinternet en iptv op Ubiquiti unifi usg router zonder experiabox

  • 3 november 2017
  • 54 reacties
  • 33125 keer bekeken

Reputatie 1
Hallo allemaal,

Aangezien ik er erg lang mee bezig ben geweest en er veel onvolledige beschrijvingen zijn hoe glasvezelinternet en iptv werkend te krijgen op een unifi usg router, hierbij een 'beschrijving van een mogelijkheid om dit werkend te krijgen

Buiten de unifi router moet je in ieder geval één managed switch hebben en het geheel via de unificontroller met recente firmware managen. Hiervoor zijn veel beschrijvingen aanwezig.
Open de unificontroller op de https poort die eraan is toegewezen en log in. Adopt alle aparaten die je van ubiquiti hebt. In ieder geval dus de router en de switch.
Maak als eerste een tweetal vlans aan (onder: settings – networks - create new network).
- Naam: IPTV – purpose: VLAN only – VLAN: 4 - vink enable igmp Snooping aan - save
- Naam: Internet – purpose: VLAN only – VLAN: 34 - vink enable igmp Snooping aan - save
Maak vervolgens een LAN aan ( settings – networks - create new network)
- Naam: LAN – purpose: corporate – Parent interface: vink LAN aan – gateway subnet: bijvoorbeeld: 192.168.1.1/24 – domain name: localdomain – vink enable igmp niet aan – dhcp range 192.168.1.2 – 192.168.1.254 – dhcp name service auto – enable dhcp winserver niet aanvinken – dhcp lease time 86400 – enable dhcp guarding niet aanvinken – save
Hierna ga je naar de router: devices – klik op de unifi securiti gateway. In het rechtermenu onder properties van de gateway klik je op configuration – WAN – connection type Using dhcp – preferred DNS: xxx.xx.xx.xx en als alternate het secundary DNS xxx.xx.xx.xx – use VLAN: 34 en que changes.
De bovenstaande DNS adressen zijn te vinden in je experiabox, log in op de experiabox met 192.168.2.254 en je gebruikersnaam en wachtwoord. Onder start (index) staan de DNS adressen onder INTERNET primary DNS en secundary DNS .
Ga naar devices unifi switch en klik daarop. In het rechtermenu onder properties stel je voor iptv (bijvoorbeeld) poort 8 in. Klik op ports en klik op het potloodje achter port 8. Kies POE off en bij networks/vlan: IPTV (4). Advanced options laten staan op switching en auto. Kies apply.

Het softwarematige is gereed nu het hardwarematige:
Sluit de ethernetkabel uit het glasvezelkastje (NTU) direct op poort 1 van de managed switch (automatisch wordt dit een trunk, daar hoef je niets voor in te stellen).
Kies poort 8 voor de verbinding naar je IPTV en sluit daar de ethernetkabel naar je iptv kastje op aan.
Het belangrijkste is nu wachten. Als je eerst internet aansluit en daarna IPTV werkt het niet!
Als IPTV werkt kun je de Unifi router aansluiten op poort 2 LAN switch met de Poort WAN van de router. Vervolgens Poort 3 van de switch op de LAN1 van de router.
Als dit werkt kun je genieten van de in mijn ogen superieure kwaliteit van de router.
Mocht bovenstaande niet werken, dan kun je ook eerst internet werkend krijgen en vervolgens alles loskoppelen en opnieuw beginnen zodat IPTV als eerste wordt aangesloten op de switch.
Ik hoop dat het lukt,

54 reacties

Reputatie 8
Ik heb al kunnen capturen/sniffen tussen de EBv10 en het NT kastje, maar ik kan daar niet de username/password vinden in de SIP sessie zoals die gebruikt worden in de fora met EBv8.
Dat lijkt een dood spoor.

Door de wellicht oudere hard- en firmware beperkingen van een Experia Box V8, kun je de inlog- en wachtwoord gegevens daarmee wel achterhalen (of nog ouder met de ZyXEL P2812-HNU-F1).
Dat hebben naar ik vermoed vele gebruikers-, en ikzelf eerder dan ook gedaan.

Vanuit de V10 --zowel bij Telfort account als iemand bij KPN-- (en de Experia Box V10A) nog vóór binnenkomst in de modem/router heb ikzelf ook "captures" gemaakt. Kan daarbij alle SIP-gegevens achterhalen --behalve het wachtwoord--. Dat is met een MD5 checksum versleuteling weergegeven, maar daar nog overheen gekoppeld een bepaalde onbekende rekenmatrix.
Daar kom je dus niet meer aan uit om het wiskundig "terug" te rekenen.

Nou ja, omdat ik voor mezelf de uitkomsten al heb via een V8, zijn er meer variabelen bekend.
Het wordt daarmee puur een "wiskundig" probleem om dat met de geëigende algoritmen terug te rekenen. Maar dat gaat mezelf net een stap te ver boven mijn pet.

Je zou via "marktplaats" een Telfort Experia Box V8 kunnen scoren.
Meestal iets van pakweg € 10,- plus verzendkosten. Dan kun je het alsnog achterhalen.

Maar je zou beter kunnen overwegen om een VOIP-account bij bijv. CheapConnect te openen, je telefoonnummer daarheen te verhuizen. Heb je met de hele Telfort VOIP niets te maken.
De kosten ervan heb je in "no-time" terugverdient door de aanzienlijk lagere telefoonkosten.

Daarnaast kun je alsnog van een nog goedkopere VOIP-provider gebuik maken om uit te bellen.
(Bijv. VoipBuster). Veel meer mogelijkheden, voor minder geld.

Als voorbeeld:
Via mijn laptop maak ik gebruik om via WiFi met een "3CX soft phone" applicatie te bellen.
Die verbindt ook op lokatie naar mijn VOIP-providers (CheapConnect en VoipBuster),
en kan op lokatie daar eventueel ook op teruggebeld worden (op het account bij CheapConnect).
"Handsfree" over microfoon en speaker, of als het meer besloten moet zijn met een headset op, nog steeds "handsfree" ;)

Advies m.b.t. VOIP:
Alleen om uit te bellen, een mix in de kosten naar vaste nummers en mobiele nummers,
heeft de volgende VOIP-provider daarin een goede balans:
https://www.powervoip.com/dashboard

Uitbellen specifiek alleen naar vaste nummers, met een ander "verdienmodel" goedkoop naar vaste nummers, maar duur naar mobiele nummers, van hetzelfde moederbedrijf:
https://www.voipbuster.com/dashboard
Hi Babylonia (en de rest),

Bedankt voor alle tips. Ik heb sinds vorige week de Experiabox V10 aan de kant gezet, en mijn USG (en andere Unifi spulletjes in gebruik) met de routed IPTV van Telfort.

Ik ben nog niet helemaal 100% blij met de manier van aanpassen van de route als de IPTV lease wordt vernieuwd, maar dat is voor het moment prima.

Waar ik wel erg mee zit, is het telefonie gedeelte. Telefonie werkt wel als ik de EBv10 direct aan het NT kastje koppel. Ik kan dan prima bellen/gebeld worden.
Maar ik wil de EBv10 gewoon helemaal kwijt, en zou een DECT VOIP toestelletje willen gebruiken, met de Telfort VOIP servers.
Ik heb al kunnen capturen/sniffen tussen de EBv10 en het NT kastje, maar ik kan daar niet de username/password vinden in de SIP sessie zoals die gebruikt worden in de fora met EBv8.
Dat lijkt een dood spoor.

Een belletje met de helpdesk leverde niets op, volgens mij begreep de medewerker niet eens wat ik bedoelde met 'mijn SIP gegevens'.

Ook het aansluiten van de EBv10 achter mijn switch (en wel zo dat de EBv10 een intern IP moet krijgen op vlan34 van de USG), krijg ik ook het SIP niet werkend.

Zijn er hier nog tips voordat ik echt een andere VOIP provider moet gaan zoeken?

Mvgr,

Ron
Reputatie 8
Er is hier op het forum eerder door gebruikers daar wel informatie over geschreven.

https://forum.telfort.nl/randapparatuur-272/werkend-glasvezelinternet-en-iptv-op-ubiquiti-unifi-usg-router-zonder-experiabox-72204

https://forum.telfort.nl/randapparatuur-272/werkend-glasvezelinternet-en-iptv-op-ubiquiti-unifi-usg-router-zonder-experiabox-72204/index2.html#post624517

https://forum.telfort.nl/randapparatuur-272/edge-router-lite-en-telfort-tv-76808#post633230
Hi dank voor de heldere uitleg, mijn hardware manage switch en USG van ubiquiti zouden dat m.i moeten kunnen (althans zei de monteur 🙂 ) nu dus uitzoeken hoe en wat, is daar meer info over bekend?
Reputatie 8
Het nieuwe glas heeft nl geen vlan meer, (lees 1 utp poort) dus zou je daar direct je USG aan kunnen hangen?
Nee, het is net andersom. Bij het nieuwe glasvezel wordt na conversie van optisch naar ethernet wel gebruik gemaakt van één UTP-poort, maar het signaal erover bestaat specifiek uit twee verschillende VLAN netwerken. Dat moet eerst in de Telfort modem/router (Experia Box V10 / V10a) worden gesplitst naar "leesbare" internet data, TV-signaal en VOIP.

Dus er komt nogal wat bij kijken als je de Telfort modem/router wilt vervangen voor eigen apparatuur. Niet alleen moet de hardware aan de benodigde specificaties voldoen (veel apparatuur voldoet er niet aan en kan derhalve niet worden gebruikt). Maar tevens moeten ook de juiste instellingen worden ingevoerd om het werkend te krijgen.
Hallo,
Kan iemand mij aangeven of dit voor het oude (lees 2 utp poorten 1 voor internet en 1 voor iptv) en nieuwe glasvezel netwerk geldt?
Het nieuwe glas heeft nl geen vlan meer, (lees 1 utp poort) dus zou je daar direct je USG aan kunnen hangen?
NEXT-HOP
heb ik gedaan via het bovenste script dat te vinden is op https://kriegsman.io/

Vervolgens heb ik dit script eenmaal gedraait en het next-hop adres toegevoegd aan de config.gateway.json.

Na het provisioning en opnieuw opstarten werkt het hier. Ik weet niet of het voor iedereen 100% werkt, aangezien het hier nu nog maar 10 minuten draait :D


Hi @3xNiks,
Ik zou ook graag IPTV werkend hebben op m'n USG, maar ben nogal een noob op het gebied van routing. Ik heb je script overgenomen maar kom niet helemaal uit het next hop gedeelte. Waar geef ik de twee commando's van Kriegsman? In de terminal van de switch?

En klopt het dat de DPI van de USG niet werkt met deze json? Dat de controller denkt dat de WAN down is? Ik las dat ergens.

Mvg,
Henk
Reputatie 1
Onlangs even aan de slag geweest met de configuratie van knutselkoning. Ik wil mijn experiabox v8 vervangen door de USG pro 4. Ik kwam de configuratie van knutselkoning tegen op het tweakers forum (althans, hij lijkt exact hetzelfde, dus ik gok dat hij hier vandaan is gekomen 😉 ), maar kom er niet helemaal uit om het aan de gang te krijgen.

Ik heb de file aangepast zodat de juiste eth verwijzingen er in staan, de USG pro heeft 2x lan en 2x wan. Volgens mij moet ik eth0 en eth2 gebruiken, want ik vond ergens dit lijstje.

eth0 = LAN1
eth1 = LAN2
eth2 = WAN1
eth3 = WAN2

Ik heb vervolgens in de experiabox de mac adressen opgezocht:


en deze in de config.gateway.json gezet. Mijn config ziet er nu zo uit: https://pastebin.com/3CM8pmQY

Als ik vervolgens de kabel vanuit de NTU in de wan1 poort stop lijkt er vrij weinig te gebeuren, ik zien geen ipadres verschijnen voor de WAN interface en ook in de log gebeurt er vrij weinig.

Volgens mij mis ik nog wat stappen. @Knutselkoning gaf aan de uitleg van basmeerman (https://github.com/basmeerman/unifi-usg-kpn) te hebben gebruikt als uitgangspunt. In die uitleg wordt nog e.e.a gedaan voordat er met de config file wordt begonnen.

1. Setup basic Internet

  1. In the Unifi Controller -> Devices -> USG
  2. In tab: Information copy the devices MAC address (you'll need it in step 5).
  3. Type: [code]pppoe[/code]
  4. Check the checkbox [code]VLAN[/code], enter the value [code]6[/code]
  5. Set the username to: Past the MAC address AND replace the semicolons (":") with dashes ("-") AND postfix it with [code]@internet[/code]. The format should look like: [code]xx-xx-xx-xx-xx-xx@internet[/code].
  6. Set the password to: [code]kpn[/code].
  7. Click: Queue change.
  8. Go to: Device Management and click Force provision
All done, you should now have Internet in your LAN.

Ik loop hierbij al vast bij stap 2, ik heb geen "Information" tab in de controller.
Reputatie 1
Goedendag,

Hoe zit het nu met doorgifte van telefonie? Is dit al werkend te krijgen met bv Experia achter de USG (puur voor telefonie) of moet dit ook bij Telfort op een aparte manier gebeuren?
Reputatie 8
Badge +11
Persoonlijk verzoek van mij: willen jullie niet steeds de hele bende quoten, maar gewoon reageer gebruiken? Dat houdt het een stuk leesbaarder.
Graag alleen quoten als anders niet duidelijk is waarop je reageert.

Mijn dank
Reputatie 1
Excuus, je hebt helemaal gelijk. Ik was in de war met mijn 2 extra (SFP) poorten op de switch. Ik maak dus wel gebruik van zo'n SetupBox, de ARRIS VIP2952V2
Beste,

Net zoals vele andere ben ik bezig geweest om mijn Experiabox v10 te vervangen voor een Unify Security Gateway 3. Na vele pogingen heb ik het werkend gekregen en deel ik graag mijn configuratie. Mijn werkende configuratie is als volgt:

NTU > USG > Unify switch8 150w > Unify Cloudkey, LAN netwerk, IPTV decoder

Om dit werkend te krijgen heb ik het volgende gedaan:
In eerste instantie een lokaal netwerk maken: USG in de switch, cloudkey in de switch en je apparaat (bijvoorbeeld je laptop) waarmee je de configuratie aanpast. Via de cloudkey heb ik de wizard gevolgd, vervolgens de USG adopt en daarna statische IP adressen ingesteld:
- USG: 192.168.10.1
- Cloudkey: 192.168.10.2
- Switch: 192.168.10.3

Hierna heb ik deze configuratie afgesloten en heb ik de USG gekoppeld aan de NTU (WAN1), vervolgens de Switch aangesloten (LAN1) met de betreffende apparaten. Hierna heb ik vlan34 geconfigureerd voor internettoegang volgens de stappen van gebruiker Warsong:

- Naam: Internet
- Purpose: VLAN only
- VLAN: 34
- IGMP Snooping: Aan
- DHCP Guarding: Uit
- save

Maak vervolgens een LAN aan of als deze al bestaat controleer deze met onderstaande. ( settings – networks - create new network)
- Naam: LAN
- Purpose: corporate
- Parent interface: LAN
- Gateway subnet: 192.168.10.1/24
- Domain name: localdomain
- Enable IGMP Snooping: Uit
- DHCP Mode: DHCP Server
- DHCP range 192.168.10.50 – 192.168.10.150
- DHCP Name Server: Auto
- DHCP Lease Time: 86400
- DHCP Gateway IP: Auto
- DHCP Unifi Controller: 192.168.10.2
- DHCP Guarding: Uit
- UPnP LAN: Uit
- Advanced DHCP options: Allemaal Uit
- Configure IPv6 Network: None
- Save


Om de rest werkend te krijgen heb ik deze configuratie samengesteld, hiervoor gebruikte ik de basis van Knutselkoning en heb ik het e.e.a aangepast wat ik las op internet. Deze configuratie is gecheckt d.m.v het commando: python -m json.tool /srv/unifi/data/sites/default/config.gateway.json op de cloudkey.

Hier is mijn werkende configuratie te vinden:
https://jsonblob.com/38d791d6-755d-11e8-b9d7-c561105b5238

In deze configuratie dient het volgende aangepast te worden: MAC VLAN4, MAC VLAN34 en de next-hop

MAC:
Zoals Knutselkoning al aangaf, geeft Telfort geen 2 DHCP leases aan hetzelfde MAC adres. Hiervoor heb ik vooraf de Experiabox gesnifft en kwam erachter dat zij een fysiek macadres gebruiken (die ook als sticker op de Experiabox staat) en een virtuele (die in mijn geval 1 cijfer verschilde). Mogelijk werkt het ook als er 2 verschillende MAC adressen gebruikt wordt (spoofing).

Zie post 2, voor het vervolg:


Bedankt voor de snelle en uitgebreide uitleg! Ik ben helaas niet in de gelegenheid nu om jouw stappenplan te volgen dus je hoort snel of het bij mij werkt. Wel alvast een aantal vragen:

- Je maakt een VLAN-only netwerk voor VLAN34 aan die je vervolgens nergens gebruikt. Wordt deze via de config.gateway.json aangeroepen o.i.d.? Of pas je deze toe op de port die met de NTU is verbonden?
- Gebruik je nu het fysieke of virtuele MAC adres in de config.gateway.json? Ik begrijp uit je verhaal dat er verschil in kan zitten maar niet welke je uiteindelijk hebt gebruikt.
- Gebruik jij meerdere STB's? Zo ja, kan je vertellen of je enkel het MAC adres van één van deze STB's in de config.gateway,json moet zetten of dat je deze er allemaal in moet zetten?
- Loop je, nu je jouw configuratie hebt draaien, nog tegen problemen aan?

Alvast bedankt! :)


- Dit had ik wat mogen nuanceren, nadat het netwerk is aangemaakt > Devices > USG > Config > WAN > instellen op DHCP, kiezen uit een DNS naar uw voorkeur en hier VLAN34 aanvinken. Hierdoor kreeg ik verbinding met het internet. Mogelijk had ik dit ook kunnen verwerken in het config.gateway.json bestand, maar ik heb nog niet heel veel ervaring met deze configuratie.
- Ook dit kon ik wat nuanceren, Ik gebruik beide MAC adressen in mijn config.gateway.json. Het eerste MAC-adres (fysieke) gebruik ik voor VLAN34, de virtuele voor VLAN4
- Ik maak geen gebruik van STB's op het moment, helaas kan ik daar nu niks over roepen.
- Op het moment heb ik nog geen problemen ondervonden, wel merkte ik op dat het netwerk op een moment redelijk traag reageerde, dit kan mogelijk ook een hickup zijn van mijn geconfigureerde DNS-servers. Daar ben ik nog niet over uit.


Bedankt! Nog wel een vraag over jouw antwoord over de STB's. Jij hebt het in jouw eerste post over een IPTV decoder terwijl je in jouw laatste post aangeeft dat je geen gebruik maakt van een STB (SetupBox). Bedoelen we beide niet hetzelfde? 😃 Als je geen gebruik maakt van een STB (of een IPTV decoder 😉 ) dan is het niet nodig om met config.gateway.json e.d. te werken.
Reputatie 1
Beste,

Net zoals vele andere ben ik bezig geweest om mijn Experiabox v10 te vervangen voor een Unify Security Gateway 3. Na vele pogingen heb ik het werkend gekregen en deel ik graag mijn configuratie. Mijn werkende configuratie is als volgt:

NTU > USG > Unify switch8 150w > Unify Cloudkey, LAN netwerk, IPTV decoder

Om dit werkend te krijgen heb ik het volgende gedaan:
In eerste instantie een lokaal netwerk maken: USG in de switch, cloudkey in de switch en je apparaat (bijvoorbeeld je laptop) waarmee je de configuratie aanpast. Via de cloudkey heb ik de wizard gevolgd, vervolgens de USG adopt en daarna statische IP adressen ingesteld:
- USG: 192.168.10.1
- Cloudkey: 192.168.10.2
- Switch: 192.168.10.3

Hierna heb ik deze configuratie afgesloten en heb ik de USG gekoppeld aan de NTU (WAN1), vervolgens de Switch aangesloten (LAN1) met de betreffende apparaten. Hierna heb ik vlan34 geconfigureerd voor internettoegang volgens de stappen van gebruiker Warsong:

- Naam: Internet
- Purpose: VLAN only
- VLAN: 34
- IGMP Snooping: Aan
- DHCP Guarding: Uit
- save

Maak vervolgens een LAN aan of als deze al bestaat controleer deze met onderstaande. ( settings – networks - create new network)
- Naam: LAN
- Purpose: corporate
- Parent interface: LAN
- Gateway subnet: 192.168.10.1/24
- Domain name: localdomain
- Enable IGMP Snooping: Uit
- DHCP Mode: DHCP Server
- DHCP range 192.168.10.50 – 192.168.10.150
- DHCP Name Server: Auto
- DHCP Lease Time: 86400
- DHCP Gateway IP: Auto
- DHCP Unifi Controller: 192.168.10.2
- DHCP Guarding: Uit
- UPnP LAN: Uit
- Advanced DHCP options: Allemaal Uit
- Configure IPv6 Network: None
- Save


Om de rest werkend te krijgen heb ik deze configuratie samengesteld, hiervoor gebruikte ik de basis van Knutselkoning en heb ik het e.e.a aangepast wat ik las op internet. Deze configuratie is gecheckt d.m.v het commando: python -m json.tool /srv/unifi/data/sites/default/config.gateway.json op de cloudkey.

Hier is mijn werkende configuratie te vinden:
https://jsonblob.com/38d791d6-755d-11e8-b9d7-c561105b5238

In deze configuratie dient het volgende aangepast te worden: MAC VLAN4, MAC VLAN34 en de next-hop

MAC:
Zoals Knutselkoning al aangaf, geeft Telfort geen 2 DHCP leases aan hetzelfde MAC adres. Hiervoor heb ik vooraf de Experiabox gesnifft en kwam erachter dat zij een fysiek macadres gebruiken (die ook als sticker op de Experiabox staat) en een virtuele (die in mijn geval 1 cijfer verschilde). Mogelijk werkt het ook als er 2 verschillende MAC adressen gebruikt wordt (spoofing).

Zie post 2, voor het vervolg:


Bedankt voor de snelle en uitgebreide uitleg! Ik ben helaas niet in de gelegenheid nu om jouw stappenplan te volgen dus je hoort snel of het bij mij werkt. Wel alvast een aantal vragen:

- Je maakt een VLAN-only netwerk voor VLAN34 aan die je vervolgens nergens gebruikt. Wordt deze via de config.gateway.json aangeroepen o.i.d.? Of pas je deze toe op de port die met de NTU is verbonden?
- Gebruik je nu het fysieke of virtuele MAC adres in de config.gateway.json? Ik begrijp uit je verhaal dat er verschil in kan zitten maar niet welke je uiteindelijk hebt gebruikt.
- Gebruik jij meerdere STB's? Zo ja, kan je vertellen of je enkel het MAC adres van één van deze STB's in de config.gateway,json moet zetten of dat je deze er allemaal in moet zetten?
- Loop je, nu je jouw configuratie hebt draaien, nog tegen problemen aan?

Alvast bedankt! :)


- Dit had ik wat mogen nuanceren, nadat het netwerk is aangemaakt > Devices > USG > Config > WAN > instellen op DHCP, kiezen uit een DNS naar uw voorkeur en hier VLAN34 aanvinken. Hierdoor kreeg ik verbinding met het internet. Mogelijk had ik dit ook kunnen verwerken in het config.gateway.json bestand, maar ik heb nog niet heel veel ervaring met deze configuratie.
- Ook dit kon ik wat nuanceren, Ik gebruik beide MAC adressen in mijn config.gateway.json. Het eerste MAC-adres (fysieke) gebruik ik voor VLAN34, de virtuele voor VLAN4
- Ik maak geen gebruik van STB's op het moment, helaas kan ik daar nu niks over roepen.
- Op het moment heb ik nog geen problemen ondervonden, wel merkte ik op dat het netwerk op een moment redelijk traag reageerde, dit kan mogelijk ook een hickup zijn van mijn geconfigureerde DNS-servers. Daar ben ik nog niet over uit.
Beste,

Net zoals vele andere ben ik bezig geweest om mijn Experiabox v10 te vervangen voor een Unify Security Gateway 3. Na vele pogingen heb ik het werkend gekregen en deel ik graag mijn configuratie. Mijn werkende configuratie is als volgt:

NTU > USG > Unify switch8 150w > Unify Cloudkey, LAN netwerk, IPTV decoder

Om dit werkend te krijgen heb ik het volgende gedaan:
In eerste instantie een lokaal netwerk maken: USG in de switch, cloudkey in de switch en je apparaat (bijvoorbeeld je laptop) waarmee je de configuratie aanpast. Via de cloudkey heb ik de wizard gevolgd, vervolgens de USG adopt en daarna statische IP adressen ingesteld:
- USG: 192.168.10.1
- Cloudkey: 192.168.10.2
- Switch: 192.168.10.3

Hierna heb ik deze configuratie afgesloten en heb ik de USG gekoppeld aan de NTU (WAN1), vervolgens de Switch aangesloten (LAN1) met de betreffende apparaten. Hierna heb ik vlan34 geconfigureerd voor internettoegang volgens de stappen van gebruiker Warsong:

- Naam: Internet
- Purpose: VLAN only
- VLAN: 34
- IGMP Snooping: Aan
- DHCP Guarding: Uit
- save

Maak vervolgens een LAN aan of als deze al bestaat controleer deze met onderstaande. ( settings – networks - create new network)
- Naam: LAN
- Purpose: corporate
- Parent interface: LAN
- Gateway subnet: 192.168.10.1/24
- Domain name: localdomain
- Enable IGMP Snooping: Uit
- DHCP Mode: DHCP Server
- DHCP range 192.168.10.50 – 192.168.10.150
- DHCP Name Server: Auto
- DHCP Lease Time: 86400
- DHCP Gateway IP: Auto
- DHCP Unifi Controller: 192.168.10.2
- DHCP Guarding: Uit
- UPnP LAN: Uit
- Advanced DHCP options: Allemaal Uit
- Configure IPv6 Network: None
- Save


Om de rest werkend te krijgen heb ik deze configuratie samengesteld, hiervoor gebruikte ik de basis van Knutselkoning en heb ik het e.e.a aangepast wat ik las op internet. Deze configuratie is gecheckt d.m.v het commando: python -m json.tool /srv/unifi/data/sites/default/config.gateway.json op de cloudkey.

Hier is mijn werkende configuratie te vinden:
https://jsonblob.com/38d791d6-755d-11e8-b9d7-c561105b5238

In deze configuratie dient het volgende aangepast te worden: MAC VLAN4, MAC VLAN34 en de next-hop

MAC:
Zoals Knutselkoning al aangaf, geeft Telfort geen 2 DHCP leases aan hetzelfde MAC adres. Hiervoor heb ik vooraf de Experiabox gesnifft en kwam erachter dat zij een fysiek macadres gebruiken (die ook als sticker op de Experiabox staat) en een virtuele (die in mijn geval 1 cijfer verschilde). Mogelijk werkt het ook als er 2 verschillende MAC adressen gebruikt wordt (spoofing).

Zie post 2, voor het vervolg:


Bedankt voor de snelle en uitgebreide uitleg! Ik ben helaas niet in de gelegenheid nu om jouw stappenplan te volgen dus je hoort snel of het bij mij werkt. Wel alvast een aantal vragen:

- Je maakt een VLAN-only netwerk voor VLAN34 aan die je vervolgens nergens gebruikt. Wordt deze via de config.gateway.json aangeroepen o.i.d.? Of pas je deze toe op de port die met de NTU is verbonden?
- Gebruik je nu het fysieke of virtuele MAC adres in de config.gateway.json? Ik begrijp uit je verhaal dat er verschil in kan zitten maar niet welke je uiteindelijk hebt gebruikt.
- Gebruik jij meerdere STB's? Zo ja, kan je vertellen of je enkel het MAC adres van één van deze STB's in de config.gateway,json moet zetten of dat je deze er allemaal in moet zetten?
- Loop je, nu je jouw configuratie hebt draaien, nog tegen problemen aan?

Alvast bedankt! 🙂
Reputatie 1
NEXT-HOP
heb ik gedaan via het bovenste script dat te vinden is op https://kriegsman.io/

Vervolgens heb ik dit script eenmaal gedraait en het next-hop adres toegevoegd aan de config.gateway.json.

Na het provisioning en opnieuw opstarten werkt het hier. Ik weet niet of het voor iedereen 100% werkt, aangezien het hier nu nog maar 10 minuten draait 😃
Reputatie 1
Beste,

Net zoals vele andere ben ik bezig geweest om mijn Experiabox v10 te vervangen voor een Unify Security Gateway 3. Na vele pogingen heb ik het werkend gekregen en deel ik graag mijn configuratie. Mijn werkende configuratie is als volgt:

NTU > USG > Unify switch8 150w > Unify Cloudkey, LAN netwerk, IPTV decoder

Om dit werkend te krijgen heb ik het volgende gedaan:
In eerste instantie een lokaal netwerk maken: USG in de switch, cloudkey in de switch en je apparaat (bijvoorbeeld je laptop) waarmee je de configuratie aanpast. Via de cloudkey heb ik de wizard gevolgd, vervolgens de USG adopt en daarna statische IP adressen ingesteld:
- USG: 192.168.10.1
- Cloudkey: 192.168.10.2
- Switch: 192.168.10.3

Hierna heb ik deze configuratie afgesloten en heb ik de USG gekoppeld aan de NTU (WAN1), vervolgens de Switch aangesloten (LAN1) met de betreffende apparaten. Hierna heb ik vlan34 geconfigureerd voor internettoegang volgens de stappen van gebruiker Warsong:

- Naam: Internet
- Purpose: VLAN only
- VLAN: 34
- IGMP Snooping: Aan
- DHCP Guarding: Uit
- save

Maak vervolgens een LAN aan of als deze al bestaat controleer deze met onderstaande. ( settings – networks - create new network)
- Naam: LAN
- Purpose: corporate
- Parent interface: LAN
- Gateway subnet: 192.168.10.1/24
- Domain name: localdomain
- Enable IGMP Snooping: Uit
- DHCP Mode: DHCP Server
- DHCP range 192.168.10.50 – 192.168.10.150
- DHCP Name Server: Auto
- DHCP Lease Time: 86400
- DHCP Gateway IP: Auto
- DHCP Unifi Controller: 192.168.10.2
- DHCP Guarding: Uit
- UPnP LAN: Uit
- Advanced DHCP options: Allemaal Uit
- Configure IPv6 Network: None
- Save


Om de rest werkend te krijgen heb ik deze configuratie samengesteld, hiervoor gebruikte ik de basis van Knutselkoning en heb ik het e.e.a aangepast wat ik las op internet. Deze configuratie is gecheckt d.m.v het commando: python -m json.tool /srv/unifi/data/sites/default/config.gateway.json op de cloudkey.

Hier is mijn werkende configuratie te vinden:
https://jsonblob.com/38d791d6-755d-11e8-b9d7-c561105b5238

In deze configuratie dient het volgende aangepast te worden: MAC VLAN4, MAC VLAN34 en de next-hop

MAC:
Zoals Knutselkoning al aangaf, geeft Telfort geen 2 DHCP leases aan hetzelfde MAC adres. Hiervoor heb ik vooraf de Experiabox gesnifft en kwam erachter dat zij een fysiek macadres gebruiken (die ook als sticker op de Experiabox staat) en een virtuele (die in mijn geval 1 cijfer verschilde). Mogelijk werkt het ook als er 2 verschillende MAC adressen gebruikt wordt (spoofing).

Zie post 2, voor het vervolg:
Daar was ik al bang voor.

op de site https://jsonlint.com/ heb ik de code geplakt.

Mocht je toevallig wel bij je config kunnen zou je die misschien willen doorsturen evt via PB of een download link?

Alvast bedankt!


Hi mcclooney,
Ik zal binnenkort even een wat gedetailleerder / chronologischer stappenplan maken en dat posten...

wellicht een tip om notepad++ te gebruiken, is freeware en zitten ook wat handigheden in zoals begin-end herkenning en dergelijke 🆒 ...


Hi Knutselkoning, heb je toevallig tijd en zin gehad om stappenplan te maken? Ik heb helaas geen tijd om het een en ander uit te proberen maar zie graag hoe jij het op hebt gelost. Ik heb wel de JSON kunnen corrigeren (er stonden een paar (knip/plak) foutjes in). Deze kun je als het goed is via de volgende link bekijken:

https://jsonblob.com/e92d1fcc-74ae-11e8-bec7-23929986f0fd
Gisteravond druk bezig geweest met de code van Knutselkoning en het werkt inderdaad.

Wel loop ik tegen 2 problemen aan met mijn IPTV BOX

Pauzeren van de box werkt niet. Bij het hervatten krijg ik een foutmelding -3
Ook kan deze bij een netwerktest de NTP server vinden.

Ga hier vanavond nog even veder naar kijken.

Helaas ook het zelfde probleem met met de GUI (download bars blijven oranje)
Daar was ik al bang voor.

op de site https://jsonlint.com/ heb ik de code geplakt.

Mocht je toevallig wel bij je config kunnen zou je die misschien willen doorsturen evt via PB of een download link?

Alvast bedankt!


Hi mcclooney,
Ik zal binnenkort even een wat gedetailleerder / chronologischer stappenplan maken en dat posten...

wellicht een tip om notepad++ te gebruiken, is freeware en zitten ook wat handigheden in zoals begin-end herkenning en dergelijke 🆒 ...
Goed bezig knutselkoning.
Heb het op KPN inmiddels een tijdje draaien.
Idd hetzelfde als jouw dat je in de gui oranje tellers hebt (DNS probleem, maar als je die in gui insteld werkt iptv weer niet).
Ook dat auto script nog niet werkend, maar zolang je de USG niet reset houd je dezelfde next hop ip (en anders is het nieuwe ip in json zetten en provisionen).

Heb jij naar de laatste update geupgrade, of heb je de voorlaatste versie?


Thanks Warson!
Ik ga van de week nog eens optimaliseren, want als ik de manual van Ubiquiti volg dan zou het zo moeten zijn dat alleen hetgeen dat afwijkt van in instellingen die je in de gui maakt hoeft in te kloppen in de Json... wellicht levert dat ook ander gedrag op mbt statistics...

Ik draai trouwens op 4.4.22 (is volgens mij een stabile R.C.)
Goed bezig knutselkoning.
Heb het op KPN inmiddels een tijdje draaien.
Idd hetzelfde als jouw dat je in de gui oranje tellers hebt (DNS probleem, maar als je die in gui insteld werkt iptv weer niet).
Ook dat auto script nog niet werkend, maar zolang je de USG niet reset houd je dezelfde next hop ip (en anders is het nieuwe ip in json zetten en provisionen).

Heb jij naar de laatste update geupgrade, of heb je de voorlaatste versie?
Daar was ik al bang voor.

op de site https://jsonlint.com/ heb ik de code geplakt.

Mocht je toevallig wel bij je config kunnen zou je die misschien willen doorsturen evt via PB of een download link?

Alvast bedankt!
Hi mcclooney!
In welke editor heb je hem gemaakt / copy pasted?

In welke interface krijg je deze melding?

Ik zie ook dat de interface van t forum heeft zitten schudden met quotes :(

Ik kan nu niet bij mijn config, wellicht ff vergelijken met die van basbeerman

Succes!
Reputatie 8
Badge +10
Helaas krijg ik met deze code een foutmelding op regel 16


Tikfoutje..!?
Identifier i.p.v. dentifier.
Helaas krijg ik met deze code een foutmelding op regel 16

Reageer