Werkend glasvezelinternet en iptv op Ubiquiti unifi usg router zonder experiabox

  • 3 november 2017
  • 54 reacties
  • 27665 keer bekeken


Toon het eerste bericht

54 reacties

Reputatie 1
Badge
Zoals ik zei ik heb geen andere setup werkend gekregen, ik hoor het graag. Trouwens kun jij bevestigen of telefonie nu op een andere modem dan Telfort werkend is te krijgen? Op welke vlan zit dat dan, aangezien je stelt dat telfort en kpn en xs4all hetzelfde zijn? Ik heb de v8 en las een verhaal over wireshark. Ik ben benieuwd.

config staat hier (forum) van mijn setup....... fritzbox 7390
Bedankt Kingofsnake, ik heb op basis van jouw omschrijving een setup gemaakt voor mijn KPN+USG.
Als ik het goed begrijp heb ik nu bridged IPTV. Ik ben nog wel aan het kijken om Routed IPTV werkend te krijgen, maar tot dan heb ik dit als backup tussen het rommelen door. :)

Buiten de USG moet je in ieder geval één managed (Unifi) switch hebben en het geheel via de unifi controller (ik gebruik Unifi Cloud Key) met recente firmware managen.
Open de unifi controller op de https poort (192.168.2.2 in mijn geval) die eraan is toegewezen en log in. Adopt alle aparaten die je van ubiquiti hebt. In ieder geval dus de router en de switch.

Maak 2 VLAN’s aan (onder: settings – networks - create new network).
- Naam: IPTV
- Purpose: VLAN only
- VLAN: 4
- IGMP Snooping: Aan
- DHCP Guarding: Uit
- save

- Naam: Internet
- Purpose: VLAN only
- VLAN: 6
- IGMP Snooping: Aan
- DHCP Guarding: Uit
- save

Maak vervolgens een LAN aan of als deze al bestaat controleer deze met onderstaande. ( settings – networks - create new network)
- Naam: LAN
- Purpose: corporate
- Parent interface: LAN
- Gateway subnet: 192.168.2.254/24
- Domain name: localdomain
- Enable IGMP Snooping: Uit
- DHCP Mode: DHCP Server
- DHCP range 192.168.2.50 – 192.168.2.250
- DHCP Name Server: Auto
- DHCP Lease Time: 86400
- DHCP Gateway IP: Auto
- DHCP Unifi Controller: 192.168.2.2
- DHCP Guarding: Uit
- UPnP LAN: Uit
- Advanced DHCP options: Allemaal Uit
- Configure IPv6 Network: None
- Save

Hierna ga je naar de router: devices – klik op de unifi securiti gateway. In het rechtermenu onder properties van de gateway klik je op configuration – WAN1
- IPv4 Connection type: PPPoE
- Username: xx-xx-xx-xx-xx-xx@internet (MAC adres van je eigen USG)
- Password: kpn
- IPv6 Connection type: Disabled
- Preferred DNS: leeg laten
- Alternate DNS: leeg laten
- Use VLAN: Aan en 6
- Queue Changes



Ga naar devices unifi switch en klik daarop. In het rechtermenu onder properties stel je voor iptv (bijvoorbeeld) poort 8 in. Klik op ports en klik op het potloodje achter port 8.
- Switch Port Profile: IPTV (4)
-POE: Off
- Operation: Switching
- Link Negotiation: Auto
- Isolation: Uit
- Storm Control: Uit (alle 3)
- LLDP MED – Enable LLDP MED: Aan (andere Uit)
- Rate Limit: Uit
- Apply

Het softwarematige is gereed nu het hardwarematige:
- Sluit de ethernetkabel uit het glasvezelkastje (NTU) direct op poort 1 van de managed switch (automatisch wordt dit een trunk, daar hoef je niets voor in te stellen).
- Kies poort 8 voor de verbinding naar je IPTV en sluit daar de ethernetkabel naar je iptv kastje op aan.

Het belangrijkste is nu wachten. Als je eerst internet aansluit en daarna IPTV werkt het niet!

Als IPTV werkt kun je de USG WAN aansluiten op poort 2 van de switch.
Vervolgens Poort 3 van de switch op de LAN1 van de USG.

Mocht Mutje nog eens langs komen dan hoor ik graag of Routed IPTV KPN+USG gelukt is 😉
Iemand hier toevallig al een update om IPTV in routed mode te krijgen en de unifi USG rechtstreeks op het NTU kastje van telfort aan te sluiten?
Het heeft wat avondjes knutselen gekost... maar uiteindelijk heb ik hier routed IPTV via een USG op Telfort glasvezel...🆒🆒🆒
(overigens iedereen bedankt voor de workarounds om het in bridge aan de gang te krijgen)

Het zal hoe dan ook via de config.gateway.json moeten. Ik draai de controller op mijn Synology Nas, daar moet de file weggeschreven worden in /volume1/@appstore/UniFi Controller 5/data/sites/default. Let op, deze file is standaard niet aanwezig. (als je een andere controller zoals een cloudkey gebruikt ff googlen, is heel makkelijk te vinden waar de file moet staan)

In principe is het mogelijk om de KPN-config van basmeerman met een paar aanpassingen te gebruiken. Deze kan je vinden op https://github.com/basmeerman/unifi-usg-kpn.

In bovengenoemde config moet je een paar dingen aanpassen, kort samengevat:
VLAN 6 wordt VLAN 34 en geen PPPoE maar DHCP.
dat ziet er dan als volgt uit:
"34": {
"description": "eth0.34 - Internet",
"firewall": {
"in": {
"name": "WAN_IN"
},
"local": {
"name": "WAN_LOCAL"
},
"out": {
"name": "WAN_OUT"
}
},


"address": [
"dhcp"
],
"description": "eth0.34 - Internet",

"dhcp-options": {

"client-option":[
"send vendor-class-identifier "IPTV_RG";"
],
"default-route": "update",
"name-server": "update",
"default-route-distance": "1"

}

}

In de rest van de configuratie zal vervolgens de interfaceverwijzing "pppoe2" vervangen moeten worden voor "eth0.34".

Ook heb ik in de static route tabel een aanpassing gemaakt ten opzichte van de config voor KPN:

"route": {
"213.75.112.0/21": {
"next-hop": {
"10.95.140.1": "''"
}
}
}

Ik was in de veronderstelling dat dit zou moeten werken... Maar helaas...

Het venijn zit hem vervolgens in het volgende:
De USG heeft (uiteraard) op zowel VLAN 4 als 34 hetzelfde MAC-adres. Om een of andere reden geeft de DHCP-server van Telfort geen 2 ip-adressen (in verschillende VLANS) aan hetzelfde MAC-adres. Als je de startup van de Experiabox via Wireshark traced zie je ook dat de DHCP-request van VLAN 34 een ander MAC-adres is als de request van VLAN 4. Het was een schot in de ruimte, maar heb het geprobeerd en blijkbaar werkt het: ik heb aan de 2 VIF's de macadressen waarop de Experiabox een lease aanvraagt toegekend en de USG opnieuw opgestart, en warempel... het werkt!

Een mac-adres ken je als volgt toe aan een VLAN:

34": {
"mac": "[macadres dat je in wilt vullen]",
"description": "eth0.34 - Internet",
.....

er zitten nog tweer issues in bovenstaande:
- er komt nog geen automatische config-update binnen (zou via een SH scriptje moeten kunnen, maar kreeg dat nu nog niet werkend)

- de UniFi controller denkt dat de WAN-verbinding down is waardoor er geen data-statistics worden bijgehouden

Los van bovenstaande onhandigheden werkt het verder prima!


Voor de volledigheid, mijn config ziet er nu zo uit:
{
"interfaces": {
"ethernet": {
"eth0": {
"description": "eth0 - FTTH",
"duplex": "auto",
"speed": "auto",
"vif": {
"4": {
"mac": "MACADRES IPTV",
"address": [
"dhcp"
],
"description": "eth0.4 - IPTV",
"dhcp-options": {
"client-option": [
"send vendor-class-identifier "IPTV_RG";"
],
"default-route": "no-update",
"default-route-distance": "210",
"name-server": "update"
}
},
"34": {
"mac": MACADRES INTERNET",
"description": "eth0.34 - Internet",
"firewall": {
"in": {
"name": "WAN_IN"
},
"local": {
"name": "WAN_LOCAL"
},
"out": {
"name": "WAN_OUT"
}
},


"address": [

"dhcp"

],

"description": "eth0.34 - Internet",

"dhcp-options": {

"client-option":[
"send vendor-class-identifier "IPTV_RG";"
],
"default-route": "update",
"name-server": "update",
"default-route-distance": "1"

}

}
}
},
"eth1": {
"description": "eth1 - LAN",
"address": [
"IPADRES USG/24"
],
"duplex": "auto",
"firewall": {
"in": {
"name": "LAN_IN"
},
"local": {
"name": "LAN_LOCAL"
},
"out": {
"name": "LAN_OUT"
}
},
"speed": "auto"
},
"eth2": {
"disable": "''",
"duplex": "auto",
"speed": "auto"
}
},
"loopback": {
"lo": "''"
}
},
"protocols": {
"igmp-proxy": {
"interface": {
"eth0.4": {
"alt-subnet": [
"0.0.0.0/0"
],
"role": "upstream",
"threshold": "1"
},
"eth1": {
"alt-subnet": [
"0.0.0.0/0"
],
"role": "downstream",
"threshold": "1"
}
}
},
"static": {
"interface-route": {
"0.0.0.0/0": {
"next-hop-interface": {
"eth0.34": {
"distance": "1"
}
}
}
},
"route": {
"213.75.112.0/21": {
"next-hop": {
"10.95.140.1": "''"
}
}
}
}
},
"port-forward": {
"auto-firewall": "enable",
"hairpin-nat": "enable",
"lan-interface": [
"eth1"
],
"wan-interface": "eth0.34"
},
"service": {
"nat": {
"rule": {
"5000": {
"description": "MASQ corporate_network to IPTV network",
"destination": {
"address": "213.75.112.0/21"
},
"log": "disable",
"outbound-interface": "eth0.4",
"protocol": "all",
"type": "masquerade"
},
"6001": {
"description": "MASQ corporate_network to WAN",
"log": "disable",
"outbound-interface": "eth0.34",
"protocol": "all",
"source": {
"group": {
"network-group": "corporate_network"
}
},
"type": "masquerade"
},
"6002": {
"description": "MASQ remote_user_vpn_network to WAN",
"log": "disable",
"outbound-interface": "eth0.34",
"protocol": "all",
"source": {
"group": {
"network-group": "remote_user_vpn_network"
}
},
"type": "masquerade"
},
"6003": {
"description": "MASQ guest_network to WAN",
"log": "disable",
"outbound-interface": "eth0.34",
"protocol": "all",
"source": {
"group": {
"network-group": "guest_network"
}
},
"type": "masquerade"
}
}
}
}
}
Helaas krijg ik met deze code een foutmelding op regel 16

Reputatie 8
Badge +9
Helaas krijg ik met deze code een foutmelding op regel 16


Tikfoutje..!?
Identifier i.p.v. dentifier.
Hi mcclooney!
In welke editor heb je hem gemaakt / copy pasted?

In welke interface krijg je deze melding?

Ik zie ook dat de interface van t forum heeft zitten schudden met quotes :(

Ik kan nu niet bij mijn config, wellicht ff vergelijken met die van basbeerman

Succes!
Daar was ik al bang voor.

op de site https://jsonlint.com/ heb ik de code geplakt.

Mocht je toevallig wel bij je config kunnen zou je die misschien willen doorsturen evt via PB of een download link?

Alvast bedankt!
Goed bezig knutselkoning.
Heb het op KPN inmiddels een tijdje draaien.
Idd hetzelfde als jouw dat je in de gui oranje tellers hebt (DNS probleem, maar als je die in gui insteld werkt iptv weer niet).
Ook dat auto script nog niet werkend, maar zolang je de USG niet reset houd je dezelfde next hop ip (en anders is het nieuwe ip in json zetten en provisionen).

Heb jij naar de laatste update geupgrade, of heb je de voorlaatste versie?
Goed bezig knutselkoning.
Heb het op KPN inmiddels een tijdje draaien.
Idd hetzelfde als jouw dat je in de gui oranje tellers hebt (DNS probleem, maar als je die in gui insteld werkt iptv weer niet).
Ook dat auto script nog niet werkend, maar zolang je de USG niet reset houd je dezelfde next hop ip (en anders is het nieuwe ip in json zetten en provisionen).

Heb jij naar de laatste update geupgrade, of heb je de voorlaatste versie?


Thanks Warson!
Ik ga van de week nog eens optimaliseren, want als ik de manual van Ubiquiti volg dan zou het zo moeten zijn dat alleen hetgeen dat afwijkt van in instellingen die je in de gui maakt hoeft in te kloppen in de Json... wellicht levert dat ook ander gedrag op mbt statistics...

Ik draai trouwens op 4.4.22 (is volgens mij een stabile R.C.)
Daar was ik al bang voor.

op de site https://jsonlint.com/ heb ik de code geplakt.

Mocht je toevallig wel bij je config kunnen zou je die misschien willen doorsturen evt via PB of een download link?

Alvast bedankt!


Hi mcclooney,
Ik zal binnenkort even een wat gedetailleerder / chronologischer stappenplan maken en dat posten...

wellicht een tip om notepad++ te gebruiken, is freeware en zitten ook wat handigheden in zoals begin-end herkenning en dergelijke 🆒 ...
Gisteravond druk bezig geweest met de code van Knutselkoning en het werkt inderdaad.

Wel loop ik tegen 2 problemen aan met mijn IPTV BOX

Pauzeren van de box werkt niet. Bij het hervatten krijg ik een foutmelding -3
Ook kan deze bij een netwerktest de NTP server vinden.

Ga hier vanavond nog even veder naar kijken.

Helaas ook het zelfde probleem met met de GUI (download bars blijven oranje)
Reputatie 1
Daar was ik al bang voor.

op de site https://jsonlint.com/ heb ik de code geplakt.

Mocht je toevallig wel bij je config kunnen zou je die misschien willen doorsturen evt via PB of een download link?

Alvast bedankt!


Hi mcclooney,
Ik zal binnenkort even een wat gedetailleerder / chronologischer stappenplan maken en dat posten...

wellicht een tip om notepad++ te gebruiken, is freeware en zitten ook wat handigheden in zoals begin-end herkenning en dergelijke 🆒 ...


Hi Knutselkoning, heb je toevallig tijd en zin gehad om stappenplan te maken? Ik heb helaas geen tijd om het een en ander uit te proberen maar zie graag hoe jij het op hebt gelost. Ik heb wel de JSON kunnen corrigeren (er stonden een paar (knip/plak) foutjes in). Deze kun je als het goed is via de volgende link bekijken:

https://jsonblob.com/e92d1fcc-74ae-11e8-bec7-23929986f0fd
Reputatie 1
Beste,

Net zoals vele andere ben ik bezig geweest om mijn Experiabox v10 te vervangen voor een Unify Security Gateway 3. Na vele pogingen heb ik het werkend gekregen en deel ik graag mijn configuratie. Mijn werkende configuratie is als volgt:

NTU > USG > Unify switch8 150w > Unify Cloudkey, LAN netwerk, IPTV decoder

Om dit werkend te krijgen heb ik het volgende gedaan:
In eerste instantie een lokaal netwerk maken: USG in de switch, cloudkey in de switch en je apparaat (bijvoorbeeld je laptop) waarmee je de configuratie aanpast. Via de cloudkey heb ik de wizard gevolgd, vervolgens de USG adopt en daarna statische IP adressen ingesteld:
- USG: 192.168.10.1
- Cloudkey: 192.168.10.2
- Switch: 192.168.10.3

Hierna heb ik deze configuratie afgesloten en heb ik de USG gekoppeld aan de NTU (WAN1), vervolgens de Switch aangesloten (LAN1) met de betreffende apparaten. Hierna heb ik vlan34 geconfigureerd voor internettoegang volgens de stappen van gebruiker Warsong:

- Naam: Internet
- Purpose: VLAN only
- VLAN: 34
- IGMP Snooping: Aan
- DHCP Guarding: Uit
- save

Maak vervolgens een LAN aan of als deze al bestaat controleer deze met onderstaande. ( settings – networks - create new network)
- Naam: LAN
- Purpose: corporate
- Parent interface: LAN
- Gateway subnet: 192.168.10.1/24
- Domain name: localdomain
- Enable IGMP Snooping: Uit
- DHCP Mode: DHCP Server
- DHCP range 192.168.10.50 – 192.168.10.150
- DHCP Name Server: Auto
- DHCP Lease Time: 86400
- DHCP Gateway IP: Auto
- DHCP Unifi Controller: 192.168.10.2
- DHCP Guarding: Uit
- UPnP LAN: Uit
- Advanced DHCP options: Allemaal Uit
- Configure IPv6 Network: None
- Save


Om de rest werkend te krijgen heb ik deze configuratie samengesteld, hiervoor gebruikte ik de basis van Knutselkoning en heb ik het e.e.a aangepast wat ik las op internet. Deze configuratie is gecheckt d.m.v het commando: python -m json.tool /srv/unifi/data/sites/default/config.gateway.json op de cloudkey.

Hier is mijn werkende configuratie te vinden:
https://jsonblob.com/38d791d6-755d-11e8-b9d7-c561105b5238

In deze configuratie dient het volgende aangepast te worden: MAC VLAN4, MAC VLAN34 en de next-hop

MAC:
Zoals Knutselkoning al aangaf, geeft Telfort geen 2 DHCP leases aan hetzelfde MAC adres. Hiervoor heb ik vooraf de Experiabox gesnifft en kwam erachter dat zij een fysiek macadres gebruiken (die ook als sticker op de Experiabox staat) en een virtuele (die in mijn geval 1 cijfer verschilde). Mogelijk werkt het ook als er 2 verschillende MAC adressen gebruikt wordt (spoofing).

Zie post 2, voor het vervolg:
Reputatie 1
NEXT-HOP
heb ik gedaan via het bovenste script dat te vinden is op https://kriegsman.io/

Vervolgens heb ik dit script eenmaal gedraait en het next-hop adres toegevoegd aan de config.gateway.json.

Na het provisioning en opnieuw opstarten werkt het hier. Ik weet niet of het voor iedereen 100% werkt, aangezien het hier nu nog maar 10 minuten draait 😃
Reputatie 1
Beste,

Net zoals vele andere ben ik bezig geweest om mijn Experiabox v10 te vervangen voor een Unify Security Gateway 3. Na vele pogingen heb ik het werkend gekregen en deel ik graag mijn configuratie. Mijn werkende configuratie is als volgt:

NTU > USG > Unify switch8 150w > Unify Cloudkey, LAN netwerk, IPTV decoder

Om dit werkend te krijgen heb ik het volgende gedaan:
In eerste instantie een lokaal netwerk maken: USG in de switch, cloudkey in de switch en je apparaat (bijvoorbeeld je laptop) waarmee je de configuratie aanpast. Via de cloudkey heb ik de wizard gevolgd, vervolgens de USG adopt en daarna statische IP adressen ingesteld:
- USG: 192.168.10.1
- Cloudkey: 192.168.10.2
- Switch: 192.168.10.3

Hierna heb ik deze configuratie afgesloten en heb ik de USG gekoppeld aan de NTU (WAN1), vervolgens de Switch aangesloten (LAN1) met de betreffende apparaten. Hierna heb ik vlan34 geconfigureerd voor internettoegang volgens de stappen van gebruiker Warsong:

- Naam: Internet
- Purpose: VLAN only
- VLAN: 34
- IGMP Snooping: Aan
- DHCP Guarding: Uit
- save

Maak vervolgens een LAN aan of als deze al bestaat controleer deze met onderstaande. ( settings – networks - create new network)
- Naam: LAN
- Purpose: corporate
- Parent interface: LAN
- Gateway subnet: 192.168.10.1/24
- Domain name: localdomain
- Enable IGMP Snooping: Uit
- DHCP Mode: DHCP Server
- DHCP range 192.168.10.50 – 192.168.10.150
- DHCP Name Server: Auto
- DHCP Lease Time: 86400
- DHCP Gateway IP: Auto
- DHCP Unifi Controller: 192.168.10.2
- DHCP Guarding: Uit
- UPnP LAN: Uit
- Advanced DHCP options: Allemaal Uit
- Configure IPv6 Network: None
- Save


Om de rest werkend te krijgen heb ik deze configuratie samengesteld, hiervoor gebruikte ik de basis van Knutselkoning en heb ik het e.e.a aangepast wat ik las op internet. Deze configuratie is gecheckt d.m.v het commando: python -m json.tool /srv/unifi/data/sites/default/config.gateway.json op de cloudkey.

Hier is mijn werkende configuratie te vinden:
https://jsonblob.com/38d791d6-755d-11e8-b9d7-c561105b5238

In deze configuratie dient het volgende aangepast te worden: MAC VLAN4, MAC VLAN34 en de next-hop

MAC:
Zoals Knutselkoning al aangaf, geeft Telfort geen 2 DHCP leases aan hetzelfde MAC adres. Hiervoor heb ik vooraf de Experiabox gesnifft en kwam erachter dat zij een fysiek macadres gebruiken (die ook als sticker op de Experiabox staat) en een virtuele (die in mijn geval 1 cijfer verschilde). Mogelijk werkt het ook als er 2 verschillende MAC adressen gebruikt wordt (spoofing).

Zie post 2, voor het vervolg:


Bedankt voor de snelle en uitgebreide uitleg! Ik ben helaas niet in de gelegenheid nu om jouw stappenplan te volgen dus je hoort snel of het bij mij werkt. Wel alvast een aantal vragen:

- Je maakt een VLAN-only netwerk voor VLAN34 aan die je vervolgens nergens gebruikt. Wordt deze via de config.gateway.json aangeroepen o.i.d.? Of pas je deze toe op de port die met de NTU is verbonden?
- Gebruik je nu het fysieke of virtuele MAC adres in de config.gateway.json? Ik begrijp uit je verhaal dat er verschil in kan zitten maar niet welke je uiteindelijk hebt gebruikt.
- Gebruik jij meerdere STB's? Zo ja, kan je vertellen of je enkel het MAC adres van één van deze STB's in de config.gateway,json moet zetten of dat je deze er allemaal in moet zetten?
- Loop je, nu je jouw configuratie hebt draaien, nog tegen problemen aan?

Alvast bedankt! 🙂
Reputatie 1
Beste,

Net zoals vele andere ben ik bezig geweest om mijn Experiabox v10 te vervangen voor een Unify Security Gateway 3. Na vele pogingen heb ik het werkend gekregen en deel ik graag mijn configuratie. Mijn werkende configuratie is als volgt:

NTU > USG > Unify switch8 150w > Unify Cloudkey, LAN netwerk, IPTV decoder

Om dit werkend te krijgen heb ik het volgende gedaan:
In eerste instantie een lokaal netwerk maken: USG in de switch, cloudkey in de switch en je apparaat (bijvoorbeeld je laptop) waarmee je de configuratie aanpast. Via de cloudkey heb ik de wizard gevolgd, vervolgens de USG adopt en daarna statische IP adressen ingesteld:
- USG: 192.168.10.1
- Cloudkey: 192.168.10.2
- Switch: 192.168.10.3

Hierna heb ik deze configuratie afgesloten en heb ik de USG gekoppeld aan de NTU (WAN1), vervolgens de Switch aangesloten (LAN1) met de betreffende apparaten. Hierna heb ik vlan34 geconfigureerd voor internettoegang volgens de stappen van gebruiker Warsong:

- Naam: Internet
- Purpose: VLAN only
- VLAN: 34
- IGMP Snooping: Aan
- DHCP Guarding: Uit
- save

Maak vervolgens een LAN aan of als deze al bestaat controleer deze met onderstaande. ( settings – networks - create new network)
- Naam: LAN
- Purpose: corporate
- Parent interface: LAN
- Gateway subnet: 192.168.10.1/24
- Domain name: localdomain
- Enable IGMP Snooping: Uit
- DHCP Mode: DHCP Server
- DHCP range 192.168.10.50 – 192.168.10.150
- DHCP Name Server: Auto
- DHCP Lease Time: 86400
- DHCP Gateway IP: Auto
- DHCP Unifi Controller: 192.168.10.2
- DHCP Guarding: Uit
- UPnP LAN: Uit
- Advanced DHCP options: Allemaal Uit
- Configure IPv6 Network: None
- Save


Om de rest werkend te krijgen heb ik deze configuratie samengesteld, hiervoor gebruikte ik de basis van Knutselkoning en heb ik het e.e.a aangepast wat ik las op internet. Deze configuratie is gecheckt d.m.v het commando: python -m json.tool /srv/unifi/data/sites/default/config.gateway.json op de cloudkey.

Hier is mijn werkende configuratie te vinden:
https://jsonblob.com/38d791d6-755d-11e8-b9d7-c561105b5238

In deze configuratie dient het volgende aangepast te worden: MAC VLAN4, MAC VLAN34 en de next-hop

MAC:
Zoals Knutselkoning al aangaf, geeft Telfort geen 2 DHCP leases aan hetzelfde MAC adres. Hiervoor heb ik vooraf de Experiabox gesnifft en kwam erachter dat zij een fysiek macadres gebruiken (die ook als sticker op de Experiabox staat) en een virtuele (die in mijn geval 1 cijfer verschilde). Mogelijk werkt het ook als er 2 verschillende MAC adressen gebruikt wordt (spoofing).

Zie post 2, voor het vervolg:


Bedankt voor de snelle en uitgebreide uitleg! Ik ben helaas niet in de gelegenheid nu om jouw stappenplan te volgen dus je hoort snel of het bij mij werkt. Wel alvast een aantal vragen:

- Je maakt een VLAN-only netwerk voor VLAN34 aan die je vervolgens nergens gebruikt. Wordt deze via de config.gateway.json aangeroepen o.i.d.? Of pas je deze toe op de port die met de NTU is verbonden?
- Gebruik je nu het fysieke of virtuele MAC adres in de config.gateway.json? Ik begrijp uit je verhaal dat er verschil in kan zitten maar niet welke je uiteindelijk hebt gebruikt.
- Gebruik jij meerdere STB's? Zo ja, kan je vertellen of je enkel het MAC adres van één van deze STB's in de config.gateway,json moet zetten of dat je deze er allemaal in moet zetten?
- Loop je, nu je jouw configuratie hebt draaien, nog tegen problemen aan?

Alvast bedankt! :)


- Dit had ik wat mogen nuanceren, nadat het netwerk is aangemaakt > Devices > USG > Config > WAN > instellen op DHCP, kiezen uit een DNS naar uw voorkeur en hier VLAN34 aanvinken. Hierdoor kreeg ik verbinding met het internet. Mogelijk had ik dit ook kunnen verwerken in het config.gateway.json bestand, maar ik heb nog niet heel veel ervaring met deze configuratie.
- Ook dit kon ik wat nuanceren, Ik gebruik beide MAC adressen in mijn config.gateway.json. Het eerste MAC-adres (fysieke) gebruik ik voor VLAN34, de virtuele voor VLAN4
- Ik maak geen gebruik van STB's op het moment, helaas kan ik daar nu niks over roepen.
- Op het moment heb ik nog geen problemen ondervonden, wel merkte ik op dat het netwerk op een moment redelijk traag reageerde, dit kan mogelijk ook een hickup zijn van mijn geconfigureerde DNS-servers. Daar ben ik nog niet over uit.
Reputatie 1
Beste,

Net zoals vele andere ben ik bezig geweest om mijn Experiabox v10 te vervangen voor een Unify Security Gateway 3. Na vele pogingen heb ik het werkend gekregen en deel ik graag mijn configuratie. Mijn werkende configuratie is als volgt:

NTU > USG > Unify switch8 150w > Unify Cloudkey, LAN netwerk, IPTV decoder

Om dit werkend te krijgen heb ik het volgende gedaan:
In eerste instantie een lokaal netwerk maken: USG in de switch, cloudkey in de switch en je apparaat (bijvoorbeeld je laptop) waarmee je de configuratie aanpast. Via de cloudkey heb ik de wizard gevolgd, vervolgens de USG adopt en daarna statische IP adressen ingesteld:
- USG: 192.168.10.1
- Cloudkey: 192.168.10.2
- Switch: 192.168.10.3

Hierna heb ik deze configuratie afgesloten en heb ik de USG gekoppeld aan de NTU (WAN1), vervolgens de Switch aangesloten (LAN1) met de betreffende apparaten. Hierna heb ik vlan34 geconfigureerd voor internettoegang volgens de stappen van gebruiker Warsong:

- Naam: Internet
- Purpose: VLAN only
- VLAN: 34
- IGMP Snooping: Aan
- DHCP Guarding: Uit
- save

Maak vervolgens een LAN aan of als deze al bestaat controleer deze met onderstaande. ( settings – networks - create new network)
- Naam: LAN
- Purpose: corporate
- Parent interface: LAN
- Gateway subnet: 192.168.10.1/24
- Domain name: localdomain
- Enable IGMP Snooping: Uit
- DHCP Mode: DHCP Server
- DHCP range 192.168.10.50 – 192.168.10.150
- DHCP Name Server: Auto
- DHCP Lease Time: 86400
- DHCP Gateway IP: Auto
- DHCP Unifi Controller: 192.168.10.2
- DHCP Guarding: Uit
- UPnP LAN: Uit
- Advanced DHCP options: Allemaal Uit
- Configure IPv6 Network: None
- Save


Om de rest werkend te krijgen heb ik deze configuratie samengesteld, hiervoor gebruikte ik de basis van Knutselkoning en heb ik het e.e.a aangepast wat ik las op internet. Deze configuratie is gecheckt d.m.v het commando: python -m json.tool /srv/unifi/data/sites/default/config.gateway.json op de cloudkey.

Hier is mijn werkende configuratie te vinden:
https://jsonblob.com/38d791d6-755d-11e8-b9d7-c561105b5238

In deze configuratie dient het volgende aangepast te worden: MAC VLAN4, MAC VLAN34 en de next-hop

MAC:
Zoals Knutselkoning al aangaf, geeft Telfort geen 2 DHCP leases aan hetzelfde MAC adres. Hiervoor heb ik vooraf de Experiabox gesnifft en kwam erachter dat zij een fysiek macadres gebruiken (die ook als sticker op de Experiabox staat) en een virtuele (die in mijn geval 1 cijfer verschilde). Mogelijk werkt het ook als er 2 verschillende MAC adressen gebruikt wordt (spoofing).

Zie post 2, voor het vervolg:


Bedankt voor de snelle en uitgebreide uitleg! Ik ben helaas niet in de gelegenheid nu om jouw stappenplan te volgen dus je hoort snel of het bij mij werkt. Wel alvast een aantal vragen:

- Je maakt een VLAN-only netwerk voor VLAN34 aan die je vervolgens nergens gebruikt. Wordt deze via de config.gateway.json aangeroepen o.i.d.? Of pas je deze toe op de port die met de NTU is verbonden?
- Gebruik je nu het fysieke of virtuele MAC adres in de config.gateway.json? Ik begrijp uit je verhaal dat er verschil in kan zitten maar niet welke je uiteindelijk hebt gebruikt.
- Gebruik jij meerdere STB's? Zo ja, kan je vertellen of je enkel het MAC adres van één van deze STB's in de config.gateway,json moet zetten of dat je deze er allemaal in moet zetten?
- Loop je, nu je jouw configuratie hebt draaien, nog tegen problemen aan?

Alvast bedankt! :)


- Dit had ik wat mogen nuanceren, nadat het netwerk is aangemaakt > Devices > USG > Config > WAN > instellen op DHCP, kiezen uit een DNS naar uw voorkeur en hier VLAN34 aanvinken. Hierdoor kreeg ik verbinding met het internet. Mogelijk had ik dit ook kunnen verwerken in het config.gateway.json bestand, maar ik heb nog niet heel veel ervaring met deze configuratie.
- Ook dit kon ik wat nuanceren, Ik gebruik beide MAC adressen in mijn config.gateway.json. Het eerste MAC-adres (fysieke) gebruik ik voor VLAN34, de virtuele voor VLAN4
- Ik maak geen gebruik van STB's op het moment, helaas kan ik daar nu niks over roepen.
- Op het moment heb ik nog geen problemen ondervonden, wel merkte ik op dat het netwerk op een moment redelijk traag reageerde, dit kan mogelijk ook een hickup zijn van mijn geconfigureerde DNS-servers. Daar ben ik nog niet over uit.


Bedankt! Nog wel een vraag over jouw antwoord over de STB's. Jij hebt het in jouw eerste post over een IPTV decoder terwijl je in jouw laatste post aangeeft dat je geen gebruik maakt van een STB (SetupBox). Bedoelen we beide niet hetzelfde? 😃 Als je geen gebruik maakt van een STB (of een IPTV decoder 😉 ) dan is het niet nodig om met config.gateway.json e.d. te werken.
Reputatie 1
Excuus, je hebt helemaal gelijk. Ik was in de war met mijn 2 extra (SFP) poorten op de switch. Ik maak dus wel gebruik van zo'n SetupBox, de ARRIS VIP2952V2
Reputatie 8
Badge +11
Persoonlijk verzoek van mij: willen jullie niet steeds de hele bende quoten, maar gewoon reageer gebruiken? Dat houdt het een stuk leesbaarder.
Graag alleen quoten als anders niet duidelijk is waarop je reageert.

Mijn dank
Reputatie 1
Goedendag,

Hoe zit het nu met doorgifte van telefonie? Is dit al werkend te krijgen met bv Experia achter de USG (puur voor telefonie) of moet dit ook bij Telfort op een aparte manier gebeuren?
Reputatie 1
Onlangs even aan de slag geweest met de configuratie van knutselkoning. Ik wil mijn experiabox v8 vervangen door de USG pro 4. Ik kwam de configuratie van knutselkoning tegen op het tweakers forum (althans, hij lijkt exact hetzelfde, dus ik gok dat hij hier vandaan is gekomen 😉 ), maar kom er niet helemaal uit om het aan de gang te krijgen.

Ik heb de file aangepast zodat de juiste eth verwijzingen er in staan, de USG pro heeft 2x lan en 2x wan. Volgens mij moet ik eth0 en eth2 gebruiken, want ik vond ergens dit lijstje.

eth0 = LAN1
eth1 = LAN2
eth2 = WAN1
eth3 = WAN2

Ik heb vervolgens in de experiabox de mac adressen opgezocht:


en deze in de config.gateway.json gezet. Mijn config ziet er nu zo uit: https://pastebin.com/3CM8pmQY

Als ik vervolgens de kabel vanuit de NTU in de wan1 poort stop lijkt er vrij weinig te gebeuren, ik zien geen ipadres verschijnen voor de WAN interface en ook in de log gebeurt er vrij weinig.

Volgens mij mis ik nog wat stappen. @Knutselkoning gaf aan de uitleg van basmeerman (https://github.com/basmeerman/unifi-usg-kpn) te hebben gebruikt als uitgangspunt. In die uitleg wordt nog e.e.a gedaan voordat er met de config file wordt begonnen.

1. Setup basic Internet

  1. In the Unifi Controller -> Devices -> USG
  2. In tab: Information copy the devices MAC address (you'll need it in step 5).
  3. Type: [code]pppoe[/code]
  4. Check the checkbox [code]VLAN[/code], enter the value [code]6[/code]
  5. Set the username to: Past the MAC address AND replace the semicolons (":") with dashes ("-") AND postfix it with [code]@internet[/code]. The format should look like: [code]xx-xx-xx-xx-xx-xx@internet[/code].
  6. Set the password to: [code]kpn[/code].
  7. Click: Queue change.
  8. Go to: Device Management and click Force provision
All done, you should now have Internet in your LAN.

Ik loop hierbij al vast bij stap 2, ik heb geen "Information" tab in de controller.
NEXT-HOP
heb ik gedaan via het bovenste script dat te vinden is op https://kriegsman.io/

Vervolgens heb ik dit script eenmaal gedraait en het next-hop adres toegevoegd aan de config.gateway.json.

Na het provisioning en opnieuw opstarten werkt het hier. Ik weet niet of het voor iedereen 100% werkt, aangezien het hier nu nog maar 10 minuten draait :D


Hi @3xNiks,
Ik zou ook graag IPTV werkend hebben op m'n USG, maar ben nogal een noob op het gebied van routing. Ik heb je script overgenomen maar kom niet helemaal uit het next hop gedeelte. Waar geef ik de twee commando's van Kriegsman? In de terminal van de switch?

En klopt het dat de DPI van de USG niet werkt met deze json? Dat de controller denkt dat de WAN down is? Ik las dat ergens.

Mvg,
Henk
Hallo,
Kan iemand mij aangeven of dit voor het oude (lees 2 utp poorten 1 voor internet en 1 voor iptv) en nieuwe glasvezel netwerk geldt?
Het nieuwe glas heeft nl geen vlan meer, (lees 1 utp poort) dus zou je daar direct je USG aan kunnen hangen?
Reputatie 8
Het nieuwe glas heeft nl geen vlan meer, (lees 1 utp poort) dus zou je daar direct je USG aan kunnen hangen?
Nee, het is net andersom. Bij het nieuwe glasvezel wordt na conversie van optisch naar ethernet wel gebruik gemaakt van één UTP-poort, maar het signaal erover bestaat specifiek uit twee verschillende VLAN netwerken. Dat moet eerst in de Telfort modem/router (Experia Box V10 / V10a) worden gesplitst naar "leesbare" internet data, TV-signaal en VOIP.

Dus er komt nogal wat bij kijken als je de Telfort modem/router wilt vervangen voor eigen apparatuur. Niet alleen moet de hardware aan de benodigde specificaties voldoen (veel apparatuur voldoet er niet aan en kan derhalve niet worden gebruikt). Maar tevens moeten ook de juiste instellingen worden ingevoerd om het werkend te krijgen.

Reageer