beantwoord

Ubiquiti EdgeRouter X ipv Experiabox

  • 8 april 2019
  • 49 reacties
  • 4315 keer bekeken

Reputatie 1
Goedemiddag,

Sinds enkele dagen ben ik in het bezit van een Ubiquiti EdgeRouter X die ik wil gebruiken ter vervanging van mijn Experiabox (vanwege meer opties etc), om zo via de EdgeRouter X internet en ITV te gebruiken. Vaste/VOIP telefonie heb ik niet. Ik heb met behulp van de website van Telfort, het forum van Telfort en Tweakers al veel informatie gevonden en zaken geprobeerd, maar wat ik ook doe, internet verbinding krijg ik niet, laat staan dat ITV werkt.

Nu zie ik hier op het forum best veel informatie voorbij komen, net als bij Tweakers het geval is. Alleen kom ik er domweg niet uit. De meeste voorbeelden van configuraties zijn in een CLI bij elkaar getikt en vervolgens in de router geïmporteerd (of vanuit de CLI die in EdgeOS opgenomen is), maar laat ik daar nou net absoluut geen ster in zijn.

Via de Config Tree kan je wel heel veel instellen en ik vermoedde op een zeker moment dan ook dat het nu echt wel zou moeten werken. Maar helaas. Mijn probleem nu is dat ik al zoveel heb geprobeerd dat ik niet meer weet wat ik fout doe en waar het mis gaat. Ook verschilt de informatie die ik vind vaak op details waardoor ik niet weer wat de correcte info is.

Kan iemand mij hierbij helpen? Zou echt tof zijn als ik dit alsnog aan de praat kan krijgen 😁
icon

Beste antwoord door jn987 18 april 2019, 15:14

Update: alles werkt!

Op alle poorten zit nu internet/ITV. ITV werkt ook met alle functies (on demand, opnames, gemist etc). Ik heb een combinatie van allerlei informatie en configuraties gebruikt. Maar uiteindelijk lijkt de oplossing voor het ITV gedeelte te hebben gezeten in het configureren van een static next-hop naar het juiste Ip-adres van de ITV ontvanger.

Ik zal één dezer dagen mijn werkende configuratie hier nog eens plaatsen.
Bekijk reactie

49 reacties

Reputatie 8

Zowel Fritbox als DrayTek zijn bedoeld om rechtstreeks met internet te verbinden.
(Dus vervangen van de Experia Box). Genoeg berichten hier op het forum die erover gaan.

Ook al heb je andere apparatuur van Ubiquityi (zelf heb ik ervaring met Ubiquiti “Nano-beams”), zolang er niet een goed werkende set-up mogelijk is met een router van dat merk, zou het niet mijn keus zijn. Maar goed, dat is iets om door jezelf uit te zoeken.

Weet niet of je de router al hebt gekocht, omdat je naar een prijsvergelijking verwijst.

Maar aangaande de configuratie is in dit forumdraadje, en mogelijk op het forum van KPN het meest actueel. De gebruiker "TelfortVindMijnNaamTeLang” hier wat eerder naar voren in het onderwerp, heeft onlangs ook een router van Ubiquity in gebruik, maar heeft vooralsnog niet een goed werkende set-up. Met name aangaande IPTV. Dus het lijkt moeizaam te verlopen.

Mocht je de Ubiquity router nog niet hebben gekocht, overweeg bijv. een router van Fritbox, DrayTek.

Hi welke router zou je dan adviseren? En kan een FB of DT de experia dan vervangen, of bedoeld als router achter de experia? gr Lars

ps mijn LAN bestaat uit meerdere ubiquiti switches en AP's

 

Reputatie 8

Weet niet of je de router al hebt gekocht, omdat je naar een prijsvergelijking verwijst.

Maar aangaande de configuratie is in dit forumdraadje, en mogelijk op het forum van KPN het meest actueel. De gebruiker "TelfortVindMijnNaamTeLang” hier wat eerder naar voren in het onderwerp, heeft onlangs ook een router van Ubiquity in gebruik, maar heeft vooralsnog niet een goed werkende set-up. Met name aangaande IPTV. Dus het lijkt moeizaam te verlopen.

Mocht je de Ubiquity router nog niet hebben gekocht, overweeg bijv. een router van Fritbox, DrayTek.

Hi ik ben net in het bezig van de Ubiquiti EdgeRouter 4, is deze config ook daarop van toepassing?

En is er ergens een duidelijk stap voor stap werkwijze ?

Plus wat als je 2 IPTV ontvangers hebt ?

Zit nu met een dubbele NAT en dat werkt niet echt stabiel….

Reputatie 1
Badge
Sinds dit weekend ook een Edgerouter. Ik ga deze config ook snel uitproberen.
Dank alvast hiervoor! 😘
Reputatie 8
Als er in de keten toch weer gewone switches tussen zitten zonder IGMP Snooping, kan ik het me voorstellen met dit soort applicaties.

Misschien help het, door al die speciale apparaten een vast IP-adres te geven? Hebben er aangaande die IGMP geen vreemde wisselingen plaats in het terugzoeken van eenmaal gevonden apparaten / vastgelegde routes van een stream.
Reputatie 1
24 uur heeft het goed gewerkt nu krijg ik vreemde dingen google home mini heeft geen connectie en daarna wel weer en dan weer niet en dan weer wel. gek word ik er van ook het bekende blauwe schermpje met wissel van kanaal komt me weer trouw opzoeken
Reputatie 1


deze setting is ook nog een belangrijke! welke ik na al mijn switches op igmp heb gezet nog de finishing touch was (hoop ik)
Reputatie 8
ik vond inmiddels een uitleg over igmp en het lijkt inderdaad het probleem te zijn
ik heb 1 switch die het zeker ondersteund en als ik het nu goed begrijp moet ik die tussen de router en de rest van mijn netwerk zetten en daar de iptv kastjes op aansluiten zodat het multicast verkeer niet de andere switches beïnvloed.

In ieder geval de aansluitingen waar je een TV-ontvanger bij gebruikt (en op andere poortjes andere apparaten inzet voor "gewoon" internet), is dat zeker aan te bevelen.

Maar tegenwoordig eigenlijk meer en meer voor alle aansluitingen, is dat IGMP belangrijk.
Chromecast, en aanverwante DLNA / Airplay streaming protocollen, maar ook moderne netwerk printer protocollen zijn allen multicast gerelateerd. (Je merkt het zelf wel, als je haperingen begint te krijgen).
Reputatie 1
ik heb er inderdaad een switch tussen maar ik zal moeten kijken of de hp switch dit aan heeft staan.
wat er dus gebeurd is dat als ik iptv kijk langzaam de toegang tot internet afsterft. dan is er nog een paar uur tv te kijken en vervolgens staat alles stil (nee ik keek geen tita tovenaar) ergens in die periode is het ook niet meer mogelijk om op de router in te loggen.
ik vond inmiddels een uitleg over igmp en het lijkt inderdaad het probleem te zijn
ik heb 1 switch die het zeker ondersteund en als ik het nu goed begrijp moet ik die tussen de router en de rest van mijn netwerk zetten en daar de iptv kastjes op aansluiten zodat het multicast verkeer niet de andere switches beïnvloed
Reputatie 8
Gebruik je mogelijk een switch tussen router en TV-ontvanger
zonder ondersteuning van "IGMP Snooping"?
Reputatie 1
na iets meer dan een dag alles goed draaiend te hebben werken. krijg ik de melding op de iptv dat ik moet zappen na ongeveer 30 sec dat blijft zo doorgaan tot er een reboot gegeven word van de router.
suggesties om dat laatste te verhelpen zijn welkom
Reputatie 1
Tip voor alle ubiquiti edgerouter x users
" word niet geaccepteerd in de config!!
het onderstaande word wel opgepikt de "" resulteren elke keer in een foute config
client-option "send vendor-class-identifier "IPTV_RG";" dus gebruik

client-option "send vendor-class-identifier &(del)quot;IPTV_RG&(del)quot;;"
verwijder (del)

het knippen en plakken leverde bij mij een frisse start op (config word overschreven door default)
via de config tree het stukje over de dhcp settings vlan 4 te hebben geplakt las de config uit en staat er ipv " enteken quote; dit heeft mij veel kopzorgen gegeven maar nu na een week zoeken heb ik eindelijk ook een werkend systeem (geen voip van de isp) (eigen voip)
Reputatie 1
Je stelt hiermee in dat de router alleen maar de web interface (gui) en ssh op het opgegeven ip adres beschikbaar maakt en niet op de overige ip adressen. Ik kon niet achterhalen of de gui en ssh ook op je wan/public ip beschikbaar zou zijn, maar met deze config zeker niet.
Reputatie 1
@Marcor bedankt voor de tip. Wat houdt deze setting precies in? Dat alleen de Edgerouter nog 'luistert' naar gui/ssh verbindingen?
Reputatie 1
@jn987 , dank voor het delen van je config. het gaf mij duidelijkheid hoe ik de fout uit mijn config kon halen.

Nog wel een opmerking, voeg je Edgerouter ip toe als enige listener voor gui en ssh, en disable oude protocollen. Dit is wat veiliger, ik had nog niet achterhaald of ssh dan ook vanaf internet toegankelijk zou zijn.

gui {
http-port 80
https-port 443
listen-address 192.168.0.1 (of welk ip je je Edgerouter hebt gegeven)
older-ciphers disable
}
en
ssh {
listen-address 192.168.0.1 (of welk ip je je Edgerouter hebt gegeven)
port 22
protocol-version v2
}
Reputatie 1
Bij deze mijn config, duurde even maar ik ben nogal druk geweest.

code:

firewall {
all-ping enable
broadcast-ping disable
ipv6-name WANv6_IN {
default-action drop
description "WAN inbound traffic forwarded to LAN"
enable-default-log
rule 10 {
action accept
description "Allow established/related sessions"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
ipv6-name WANv6_LOCAL {
default-action drop
description "WAN inbound traffic to the router"
enable-default-log
rule 10 {
action accept
description "Allow established/related sessions"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
rule 30 {
action accept
description "Allow IPv6 icmp"
protocol ipv6-icmp
}
rule 40 {
action accept
description "Allow dhcpv6"
destination {
port 546
}
protocol udp
source {
port 547
}
}
}
ipv6-receive-redirects disable
ipv6-src-route disable
ip-src-route disable
log-martians enable
name WAN_IN {
default-action drop
description "WAN to internal"
rule 10 {
action accept
description "Allow IGMP"
log disable
protocol igmp
}
rule 20 {
action accept
description "Allow established/related"
state {
established enable
related enable
}
}
rule 30 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
name WAN_LOCAL {
default-action drop
rule 10 {
action accept
description "Allow established/related"
state {
established enable
related enable
}
}
rule 20 {
action drop
description "Drop invalid state"
state {
invalid enable
}
}
}
receive-redirects disable
send-redirects enable
source-validation loose
syn-cookies enable
}
interfaces {
ethernet eth0 {
description "eth0 - FTTH"
dhcp-options {
default-route no-update
default-route-distance 1
name-server no-update
}
dhcpv6-pd {
no-dns
pd 0 {
interface eth1 {
prefix-id 1
service slaac
}
interface eth2 {
prefix-id 1
service slaac
}
prefix-length /48
}
rapid-commit disable
}
duplex auto
mtu 1512
speed auto
vif 4 {
address dhcp
description "eth0.4 - IPTV"
dhcp-options {
client-option "send vendor-class-identifier "IPTV_RG";"
client-option "request subnet-mask, routers, rfc3442-classless-static-routes;"
default-route no-update
default-route-distance 210
name-server no-update
}
mac XX:XX:XX:XX:XX:XX *
mtu 1500
}
vif 34 {
address dhcp
description "eth0.34 - Internet"
dhcpv6-pd {
no-dns
pd 0 {
interface eth1 {
prefix-id 1
service slaac
}
interface eth2 {
prefix-id 1
service slaac
}
prefix-length /48
}
rapid-commit disable
}
firewall {
in {
ipv6-name WANv6_IN
name WAN_IN
}
local {
ipv6-name WANv6_LOCAL
name WAN_LOCAL
}
}
ipv6 {
address {
autoconf
}
dup-addr-detect-transmits 1
}
mtu 1500
}
}
ethernet eth1 {
description Local
duplex auto
ipv6 {
dup-addr-detect-transmits 1
router-advert {
cur-hop-limit 64
link-mtu 0
managed-flag false
max-interval 600
name-server 2001:4860:4860::8888
name-server 2001:4860:4860::8844
other-config-flag false
prefix ::/64 {
autonomous-flag true
on-link-flag true
valid-lifetime 2592000
}
radvd-options "RDNSS 2001:4860:4860::8888 2001:4860:4860::8844 {};"
reachable-time 0
retrans-timer 0
send-advert true
}
}
mtu 1500
speed auto
}
ethernet eth2 {
description "Local 2"
duplex auto
mtu 1500
speed auto
}
ethernet eth3 {
duplex auto
mtu 1500
speed auto
}
ethernet eth4 {
duplex auto
mtu 1500
poe {
output off
}
speed auto
}
loopback lo {
}
switch switch0 {
address 192.168.2.1/24
description "Thuis netwerk"
ipv6 {
dup-addr-detect-transmits 1
}
mtu 1500
switch-port {
interface eth1 {
}
interface eth2 {
}
interface eth3 {
}
interface eth4 {
}
vlan-aware disable
}
}
}
protocols {
igmp-proxy {
interface eth0 {
role disabled
threshold 1
}
interface eth0.4 {
alt-subnet 0.0.0.0/0
role upstream
threshold 1
}
interface eth0.34 {
role disabled
threshold 1
}
interface switch0 {
alt-subnet 0.0.0.0/0
role downstream
threshold 1
}
}
static {
interface-route6 ::/0 {
next-hop-interface eth0.34 {
}
}
route 213.75.112.0/21 {
next-hop 10.213.96.1 {
}
}
}
}
service {
dhcp-server {
disabled false
global-parameters "option vendor-class-identifier code 60 = string;"
global-parameters "option broadcast-address code 28 = ip-address;"
hostfile-update disable
shared-network-name LAN1 {
authoritative enable
subnet 192.168.2.0/24 {
default-router 192.168.2.1
dns-server 8.8.8.8
dns-server 8.8.4.4
lease 86400
start 192.168.2.51 {
stop 192.168.2.200
}
}
}
static-arp disable
use-dnsmasq disable
}
dns {
forwarding {
cache-size 4000
listen-on switch0
name-server 2001:4860:4860::8888
name-server 2001:4860:4860::4444
name-server 8.8.8.8
name-server 8.8.4.4
options 192.168.2.1
}
}
gui {
http-port 80
https-port 443
older-ciphers enable
}
nat {
rule 5000 {
description IPTV
destination {
address 213.75.112.0/21
}
log disable
outbound-interface eth0.4
protocol all
source {
address 192.168.2.0/24
}
type masquerade
}
rule 5010 {
description "Telfort Internet"
log disable
outbound-interface eth0.34
protocol all
type masquerade
}
rule 5011 {
description IPTV
destination {
address 217.166.0.0/16
}
log enable
outbound-interface eth0.4
protocol all
type masquerade
}
}
ssh {
port 88
protocol-version v2
}
unms {
disable
}
upnp {
listen-on eth1 {
outbound-interface eth0.34
}
}
}
system {
host-name ubnt
login {
user XXXX {
authentication {
encrypted-password
plaintext-password
}
level admin
}
}
name-server 8.8.8.8
name-server 8.8.4.4
name-server 2001:4860:4860::8888
name-server 2001:4860:4860::8844
ntp {
server 0.ubnt.pool.ntp.org {
}
server 1.ubnt.pool.ntp.org {
}
server 2.ubnt.pool.ntp.org {
}
server 3.ubnt.pool.ntp.org {
}
}
syslog {
global {
facility all {
level notice
}
facility protocols {
level debug
}
}
}
time-zone UTC
traffic-analysis {
dpi enable
export enable
}
}
traffic-control {
}

* Vul bij het sterretje in de config het MAC adres van je ITV ontvanger in.
Update: alles werkt!
...............
Ik zal één dezer dagen mijn werkende configuratie hier nog eens plaatsen.


Dat klinkt goed! Ben benieuwd, zit nl met het zelfde probleem.
Reputatie 8
Badge +11
Dat is top om te lezen. Bedankt voor de terugkoppeling. En het lijkt ons zeker leuk als je de configuratie deelt. Daar hebben andere gebruikers met hetzelfde modem vast heel veel aan. 🙂
Reputatie 1
Update: alles werkt!

Op alle poorten zit nu internet/ITV. ITV werkt ook met alle functies (on demand, opnames, gemist etc). Ik heb een combinatie van allerlei informatie en configuraties gebruikt. Maar uiteindelijk lijkt de oplossing voor het ITV gedeelte te hebben gezeten in het configureren van een static next-hop naar het juiste Ip-adres van de ITV ontvanger.

Ik zal één dezer dagen mijn werkende configuratie hier nog eens plaatsen.
Reputatie 8
Helaas kan ik je niet verder helpen.
Misschien kun je elders nog kijken wat daar aan reacties staat (36 pagina's):
https://gathering.tweakers.net/forum/list_messages/1878543
Reputatie 1

Als ik eerdere reacties teruglees, hadden aanvankelijk ook andere gebruikers daar moeite mee.
In de configuratie gedownload bij KPN, zie ik de instellingen ervoor wel terugkomen.
Zelfs met meerdere alternatieve tijd-servers.


Die heb ik er in staan, geeft geen sjoege helaas. Overigens denk ik ook dat ik wat te optimistisch was. Heb nu de tv ontvanger een keer een reset gegeven en krijg nu foutmelding 301.
Ik heb de instellingen in andere configuraties zoveel mogelijk overgenomen en waar nodig aangepast naar Telfort. Echter op het ITV lees je ook veel verschillende dingen, de voert een mac adres op, de ander laat dit blanco. Ook gebruiken veel mensen een script om de juiste 'static route' in te stellen waardoor ITV werkt zoals het zou moeten, maar het eenmalig instellen zonder een script (ook al zou dat maar tijdelijk werken) wordt me niet duidelijk.
Reputatie 8
Ik heb via het menu het netwerk laten checken en de enige check die mislukt is de NTP tijdsynchronisatie.
Als ik eerdere reacties teruglees, hadden aanvankelijk ook andere gebruikers daar moeite mee.
In de configuratie gedownload bij KPN, zie ik de instellingen ervoor wel terugkomen.
Zelfs met meerdere alternatieve tijd-servers.
Reputatie 1
Ik heb het idee dat ik dicht bij het in de lucht krijgen van mijn ITV ben. Internet werkt inmiddels naar behoren.
ITV beeld blijft bij mij zwart en na een tijdje komt de melding dat ik moet zappen naar een andere zender. Echter blijft het beeld dan ook zwart en komt dezelfde melding na enige tijd weer naar voren. Ik heb via het menu het netwerk laten checken en de enige check die mislukt is de NTP tijdsynchronisatie.

Kan het zijn dat er ergens een instelling ontbreekt in de EgdeRouter die voor dit stukje zorgt? Als ik andermans config bestanden bekijk zie ik namelijk overal dezelfde instellingen geconfigureerd staan onder systeem > ntp..
Reputatie 8
Je gebruik geen VOIP / telefonie van Telfort.
Download via het KPN-forum dan eens het bestand "zonder telefoon" ofwel < DEZE >

Het bestand "config.boot" bekeken in bijv. "Notepad ++" (een handig toolje voor dit soort bestanden m.b.t. linefeeds) bevat zo te zien alle gegevens voor een juiste connectie. In dit geval wel voor verbinding bij KPN, met een ander VLAN voor internet en de wijze van aanmelden via PPPoE.

Als je in dit "KPN" config.boot-bestand de VLAN voor internet verandert naar 34, en het stuk m.b.t. aanmelden via PPPoE, uitwisselt met hetgeen je vindt in je eigen "Telfort" config.boot-bestand, --wat een automatische aanmelding is--, en specifieke aanmeldgegevens IPTV (je moet tenslotte wel de "Telfort" TV hebben); Zou je naar ik denk een werkende set-up kunnen hebben voor je Edge router, maar dan voor verbinding met Telfort.

In ieder geval met vergelijking van die twee verschillende boot bestanden, zou je naar ik denk een goed samengesteld bestand moeten krijgen voor gebruik met Telfort.

Reageer