beantwoord

Mikrotik RB450g configureren met Telfort

  • 15 november 2018
  • 126 reacties
  • 3864 keer bekeken

Reputatie 1
Glasvezel (nieuwste versie, 1 poort) experiabox v10 (geen telefonie, alleen internet/tv)

Heeft iemand een Mikrotik router werkend in deze opstelling.
Ik wil dus de Experiabox vervangen door de Mikrotik.
M.a.w. is er een begin setup hoe connectie te maken qua instellingen. (connectie, vlan etc)

Voordat ik ga beginnen, is info wel handig...dan hoef ik niet het wiel uit te vinden 🙂
icon

Beste antwoord door Galdor68 19 november 2018, 20:15

Je maakt meer kans op de tweakers site.
https://tweakers.net/merk/2806/mikrotik/forum/
Bekijk reactie

126 reacties

Reputatie 5
Badge +8
Hi bggraaf. Hoewel ik zelf niet helemaal thuis ben in de materie heb ik dit voor je kunnen vinden. Zou je deze instellingen willen proberen?
Reputatie 1
Hi bggraaf. Hoewel ik zelf niet helemaal thuis ben in de materie heb ik dit voor je kunnen vinden. Zou je deze instellingen willen proberen?


Dankje, Deze had ik al gevonden, ik heb al wat voorwerk gedaan. Maar het zou wel leuk zijn
om een voorbeeld te hebben voordat ik e.e.a. ga uitproberen in de Mikrotik.
Reputatie 1
Weinig mensen met een Mikrotik hier?
Je maakt meer kans op de tweakers site.
https://tweakers.net/merk/2806/mikrotik/forum/
Reputatie 5
Badge +8
Je maakt meer kans op de tweakers site.
https://tweakers.net/merk/2806/mikrotik/forum/


Dat is ook mijn gok.
Reputatie 1
Oke daar is even kijken dan
Reputatie 1
Na wat postings te hebben gezien e.e.a. uitgeprobeerd te hebben. Heb ik inet en iptv werkend gekregen,
Zitten hier en daar nog wat fouten in, dit is zeg maar de basis. Maar dat kan in de testomgeving verder uitgewerkt worden.

port 1 gaat naar het glasvezelmodem ( 1utp port heeft dit ding)
port 2 laptop
port 5 iptv kastje

# nov/20/2018 13:36:04 by RouterOS 6.43.2
#
# model = 450G (5 poorten)
/interface bridge
add fast-forward=no igmp-snooping=yes name=bridge-IPTV
add admin-mac=00:0C:42:5B:EA:6C auto-mac=no comment=defconf igmp-snooping=yes \
name=bridge-Internet
/interface vlan
add interface=ether1 name=vlan1.1 vlan-id=34
add interface=ether1 name=vlan1.5 vlan-id=4
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
add name=IPTV
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
add name=pool_Telfort ranges=192.168.2.10-192.168.2.50
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge-Internet name=\
defconf
add address-pool=pool_Telfort interface=ether1 name=server_Telfort
/tool user-manager customer

/interface bridge port
add bridge=bridge-Internet comment=defconf interface=ether2
add bridge=bridge-Internet comment=defconf interface=ether3
add bridge=bridge-Internet comment=defconf interface=ether4
add bridge=bridge-IPTV comment=defconf ingress-filtering=yes interface=\
vlan1.5
add bridge=bridge-IPTV interface=ether5
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge-Internet list=LAN
add comment=defconf interface=ether1 list=WAN
add interface=ether1 list=IPTV
/ip address
add address=192.168.2.3/24 comment=defconf interface=bridge-Internet network=\
192.168.2.0
add address=10.0.0.3/8 interface=ether3 network=10.0.0.0
add address=192.168.2.3/24 disabled=yes interface=vlan1.5 network=192.168.2.0

Hiermee verkrijg je het wan ip
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=\
vlan1.1

/ip dhcp-server network
add address=192.168.2.0/24 comment=defconf dns-server=8.8.8.8 gateway=\
192.168.2.3 netmask=24
/ip dns
set allow-remote-requests=yes servers=8.8.8.8
/ip dns static
add address=192.168.88.1 name=router.lan


firewall instellingen heb ik weggelaten
Reputatie 1
Badge
Ik ben zelf bezig om een CSR125 Mikrotik in te stellen volgens bovenstaand voorbeeld.
Ik heb de IPTV draaiend gekregen, maar geen internet verbinding.

Ik ben benieuwd of er sinds dit voorbeeld er nog wat wijzigingen zijn doorgevoerd en/of er een complete configuratie beschikbaar is met alle instellingen?
@chuis niet dat ik je heel veel kan helpen maar maak je gebruik van DSL of Glasvezel hier kan verschil in zitten.
Reputatie 1
Mijn config is voor glasvezel.
@bggraaf uit belangstelling werkt alles een beetje naar wens en behoren
Reputatie 1
Vlan34 en 4 ingesteld
bridge-34 en bridge 4 aangemaakt
In beide bridges 1 van de vlans gestopt met een etherport
Internet en IPTV werken dan goed vanuit die etherpoorten.
Ik wil echter via een trunkpoort beide signalen doorzetten naar een switch en dat lukt nog niet voor het iptv signaal. Ik begrijp dat ipmg snooping het iptv signaal er automatisch uiit zou halen maar ook dat lukt nog niet.

# jan/08/2019 18:24:17 by RouterOS 6.43.8
#/interface bridge
add admin-mac=B8:69:F4:6C:EC:1A auto-mac=no comment=defconf igmp-snooping=yes \
name=bridge
add igmp-snooping=yes name=bridge-iptv
/interface ethernet
set [ find default-name=ether5 ] name=ether5-Trunk
/interface vlan
add interface=ether1 name=vlan4 vlan-id=4
add interface=ether5-Trunk name=vlan4NaarTrunk use-service-tag=yes vlan-id=4
add interface=ether1 name=vlan34 vlan-id=34
add interface=ether5-Trunk name=vlan34NaarTrunk use-service-tag=yes vlan-id=\
34
/interface list
add comment=defconf name=WAN
add comment=defconf name=LAN
/ip dhcp-server option sets
add name=Vendor
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=default-dhcp ranges=192.168.2.10-192.168.2.254
add name=DHCPbridge_iptv ranges=192.168.3.5-192.168.3.10
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=defconf
add address-pool=default-dhcp disabled=no interface=bridge-iptv name=\
DHCP_IPTV_Bridge
/interface bridge port
add bridge=bridge comment=defconf interface=ether2
add bridge=bridge comment=defconf interface=ether3
add bridge=bridge-iptv comment=defconf interface=ether4
add bridge=bridge-iptv comment=defconf interface=vlan4
add bridge=bridge interface=ether5-Trunk
/ip neighbor discovery-settings
set discover-interface-list=LAN
/interface list member
add comment=defconf interface=bridge list=LAN
add comment=defconf interface=vlan34 list=WAN
add interface=vlan4 list=WAN
/ip address
add address=192.168.2.3/24 comment=defconf interface=bridge network=\
192.168.2.0
add address=192.168.3.3/24 interface=bridge-iptv network=192.168.3.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=\
vlan34
/ip dhcp-server network
add address=192.168.2.0/24 comment=defconf gateway=192.168.2.3 netmask=29
add address=192.168.3.0/24 gateway=192.168.3.3
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall filter
add action=accept chain=input comment=\
"defconf: accept established,related,untracked" connection-state=\
established,related,untracked
add action=drop chain=input comment="defconf: drop invalid" connection-state=\
invalid
add action=accept chain=input comment="defconf: accept ICMP" protocol=icmp
add action=drop chain=input comment="defconf: drop all not coming from LAN" \
in-interface-list=!LAN
add action=accept chain=forward comment="defconf: accept in ipsec policy" \
ipsec-policy=in,ipsec
add action=accept chain=forward comment="defconf: accept out ipsec policy" \
ipsec-policy=out,ipsec
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
connection-state=established,related
add action=accept chain=forward comment=\
"defconf: accept established,related, untracked" connection-state=\
established,related,untracked
add action=drop chain=forward comment="defconf: drop invalid" \
connection-state=invalid
add action=drop chain=forward comment=\
"defconf: drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
connection-state=new in-interface-list=WAN
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
ipsec-policy=out,none out-interface-list=WAN
/system clock
set time-zone-name=Europe/Amsterdam
/system identity
set name=Hex
/tool mac-server
set allowed-interface-list=LAN
/tool mac-server mac-winbox
set allowed-interface-list=LAN
Die eerste stap dat beide werkend is een mooi begin.

@Babylonia ik dacht dat je zelf geen Mikrotik gebruikt maar mischien wel een goede tip?
Reputatie 8
Zelf heb ik inderdaad geen Microtik, nee.

Vlan34 en 4 ingesteld
bridge-34 en bridge 4 aangemaakt
In beide bridges 1 van de vlans gestopt met een etherport
Internet en IPTV werken dan goed vanuit die etherpoorten.
Ik wil echter via een trunkpoort beide signalen doorzetten naar een switch en dat lukt nog niet voor het iptv signaal. Ik begrijp dat ipmg snooping het iptv signaal er automatisch uiit zou halen maar ook dat lukt nog niet.

Om van IPTV "routed mode" gebruik te maken, zou je op de LAN-poortjes, VLAN 34 als ID en "untagged" instelling kunnen configureren, en op diezelfde poortjes VLAN 4 in een "tagged" (ingepakte) instelling.

IGMP Snooping heeft daar op zichzelf niets mee te maken. Dat is een protocol om efficiënter multicast stream te verzenden. Niet op meerdere poorten aan te bieden, als het apparaat waar het naar toe moet eenmaal is gevonden en bekend is.
https://en.wikipedia.org/wiki/IGMP_snooping

A switch will, by default, flood multicast traffic to all the ports in a broadcast domain (or the VLAN equivalent). Multicast can cause unnecessary load on host devices by requiring them to process packets they have not solicited.
Reputatie 1
Badge
@chuis niet dat ik je heel veel kan helpen maar maak je gebruik van DSL of Glasvezel hier kan verschil in zitten.
ik heb net als de TS een glasverbinding
Reputatie 1
Badge
Vlan34 en 4 ingesteld
bridge-34 en bridge 4 aangemaakt



bedankt voor de configuratie!
Reputatie 1
Zelf heb ik inderdaad geen Microtik, nee.



Vlan34 en 4 ingesteld
bridge-34 en bridge 4 aangemaakt
In beide bridges 1 van de vlans gestopt met een etherport
Internet en IPTV werken dan goed vanuit die etherpoorten.
Ik wil echter via een trunkpoort beide signalen doorzetten naar een switch en dat lukt nog niet voor het iptv signaal. Ik begrijp dat ipmg snooping het iptv signaal er automatisch uiit zou halen maar ook dat lukt nog niet.
Om van IPTV "routed mode" gebruik te maken, zou je op de LAN-poortjes, VLAN 34 als ID en "untagged" instelling kunnen configureren, en op diezelfde poortjes VLAN 4 in een "tagged" (ingepakte) instelling.

IGMP Snooping


Oke duidelijk imgp

Ik heb vlan4 en vlan34 op ether1 zitten, en ether2,4 gebridged in 1 Bridge.Ether3 in de bridge-wifi
Ether5 is de trunkport met getagged vlan34 en vlan 4 (Of die getagged twee vlans op ether 5 nou de oplossing is, moet ik nog testen). Maar het werkt. Op ether2,4,5 heb ik nu zowel Internet als IPTV.
Wanneer ik een extra bridge-iptv naast de bridge gebruik heb ik alleen op die etherport die daarin zit iptv
Reputatie 1
Nu kom ik er alleen achter dat ik de HEx, alleen via het macadres kan benaderen, niet via het ipadres van de router. Dat was mij even niet opgevallen gedurende het testen.
Ik heb alle firewall rules uitgezet. www services draait. Ik kan de router op dat ipaddress wel pingen.
Strange....nou het houdt je wel bezig 🙂
Reputatie 1
Ik ben zelf bezig om een CSR125 Mikrotik in te stellen volgens bovenstaand voorbeeld.
Ik heb de IPTV draaiend gekregen, maar geen internet verbinding.

Ik ben benieuwd of er sinds dit voorbeeld er nog wat wijzigingen zijn doorgevoerd en/of er een complete configuratie beschikbaar is met alle instellingen?



Is het al gelukt?
Reputatie 8
Ik heb vlan4 en vlan34 op ether1 zitten, en ether2,4 gebridged in 1 Bridge.Ether3 in de bridge-wifi Ether5 is de trunkport met getagged vlan34 en vlan 4 (Of die getagged twee vlans op ether 5 nou de oplossing is, moet ik nog testen).....
Niet twee VLAN's getagged op een ehernetpoort zetten. Alleen voor ITV - VLAN 4
Voor internet VLAN 34 untagged aanhouden.
Reputatie 1
Badge

Ik ben zelf bezig om een CSR125 Mikrotik in te stellen volgens bovenstaand voorbeeld.
Ik heb de IPTV draaiend gekregen, maar geen internet verbinding.

Ik ben benieuwd of er sinds dit voorbeeld er nog wat wijzigingen zijn doorgevoerd en/of er een complete configuratie beschikbaar is met alle instellingen?

Is het al gelukt?

Met jouw laatste voorbeeld heb ik internet en IPTV via de mikrotik.
Wil alleen nog VLANs gaan gebruiken, maar dat lukt (nog) niet.

En daarna nog de NTU eruit en rechtstreeks op het glas, mijn mikrotik
heb ik gekocht incl. de juiste GBIC, dus dit moet lukken.
Reputatie 8
NT-kastje eruit en rechtstreeks patchen zie voorbeelden:

https://www.youtube.com/watch?v=5AuvQrQ8t74
https://www.youtube.com/watch?v=dDrYGnuBuNk

Als je een ouder type glasvezel aansluiting hebt, denk dat het dan moeilijk gaat worden het NT-kastje eruit te laten.
Reputatie 1
Badge
Ik heb de glasaansluiting uit het eerste filmpje, SC fiber heb ik al, alleen nog een SC koppelstukje scoren.

Ik heb nu wel de Mikrotik zover dat ik IPTV op 4 poorten kan aansluiten.

Wil alleen alles in een VLAN zetten, zodat ik straks via VPN hier weer gebruik van kan maken.
Alleen het VLAN gedeelte is me nu nog niet helemaal duidelijk....
Reputatie 1
Ik heb de glasaansluiting uit het eerste filmpje, SC fiber heb ik al, alleen nog een SC koppelstukje scoren.

Ik heb nu wel de Mikrotik zover dat ik IPTV op 4 poorten kan aansluiten.

Wil alleen alles in een VLAN zetten, zodat ik straks via VPN hier weer gebruik van kan maken.
Alleen het VLAN gedeelte is me nu nog niet helemaal duidelijk....


Welke MT heb je?
Reputatie 1

Ik heb vlan4 en vlan34 op ether1 zitten, en ether2,4 gebridged in 1 Bridge.Ether3 in de bridge-wifi Ether5 is de trunkport met getagged vlan34 en vlan 4 (Of die getagged twee vlans op ether 5 nou de oplossing is, moet ik nog testen).....Niet twee VLAN's getagged op een ehernetpoort zetten. Alleen voor ITV - VLAN 4
Voor internet VLAN 34 untagged aanhouden.



De MT is nu weer op zijn ip te bereiken.

Reageer