beantwoord

Experiabox vervangen

  • 29 april 2015
  • 199 reacties
  • 32324 keer bekeken

Reputatie 1
Hallo!

Jullie zullen ongetwijfeld denken "dat is het zoveelste topic over dit onderwerp". Dat klopt!
Maar hier zit het verschil: ik maak geen gebruik van ADSL / VDSL maar van het nieuwe glasvezel abonnement.

Toen ik overstapte van het oude abonnement naar het nieuwe heb ik nadrukkelijk gevraagd of ik gebruik kon blijven maken van een eigen router, zonder dat deze functionaliteit moest inleveren. Ik werd netjes in de wacht gezet zodat het nagevraagd kon worden.
Het bleek mogelijk, maar niet simpel. Dat was voor mij geen probleem en ik heb mijn abonnement verlengd.

Ik ben inmiddels een aantal weken geleden overgezet maar krijg die Experiabox met geen mogelijkheid uit mijn netwerk zonder dat alles stopt met functioneren.
De enige antwoorden die ik op het Telfort forum kan terugvinden verwijzen naar de pagina met ADSL / VDSL instellingen, maar daar heb ik uiteraard niets aan.

Op dit moment gebruik ik de DMZ functie om in ieder geval mijn eigen router in het netwerk te kunnen houden. Om twee redenen vind ik dit verre van wenselijk:
- mijn router denkt nu dat het externe IP adres 192.168.2.1 is, waardoor een hoop opties (zoals DDNS) onbruikbaar worden
- het welbekende probleem met Xbox Live: de verbinding wordt steeds verbroken, dat was niet het geval toen ik enkel mijn eigen router gebruikte

Wat ik wil bereiken, met of zonder Experiabox, is het volgende:
- het internetsignaal moet rechtstreeks bij mijn router uitkomen, zodat deze het externe IP adres ontvangt
- TV en telefonie moeten uiteraard blijven functioneren

De mogelijkheden die ik heb:
- mijn router ondersteund VLAN's om internet en TV te scheiden, mocht de Experiabox vervangen kunnen worden
- in mijn woning liggen twee netwerken, één voor internet en één voor TV, gescheiden signalen zijn dan ook geen probleem

Wie kan mij op weg helpen?
icon

Beste antwoord door peetman 30 april 2015, 11:37

Combinatie van topics op tweakers. Daar staat het ergens genoemd:
http://gathering.tweakers.net/forum/list_messages/1589287
http://gathering.tweakers.net/forum/list_messages/1632501

En als je in de Experiabox inlogt staan de VLAN's ook genoemd op de WAN pagina.
Bekijk reactie

199 reacties

Reputatie 8
Ik wil en kan eenvoudig niet de ExperiaBox in mijn Local Lan (PCs/Servers) omgeving gebruiken.
Zelf heb ik dat in mijn normale situatie ook reeds gescheiden. Het rechtstreeks aansluiten van mijn Synology router aan het NT-kastje is slechts meer als "hobby" en nieuwsgierigheid of het kan.
Na zo'n test gaat de set-up weer terug naar mijn normale situatie wat inhoudt eerst de Experia Box
(met VOIP en IP-TV). Daaraan de 2e router (de Synology RT19001ac).
Gewoon NAT achter NAT (dus een set-up met twee gescheiden LAN netwerken).

Achter de 2e router mijn servers, PC's etc.
Heb op mijn Telfort WAN IP-aansluiting een NL-domein, met eenvoudig SSL certificaat (t.b.v. uitsluitend beveiligde verbindingen als van buiten uit mijn servers worden benaderd).
(Zie de wijze hoe een en ander is ingeregeld < HIER > ).

Ik ben in die setup nog geen tekortkomingen tegengekomen in benadering van buiten uit, (bijv. VPN, of benadering van web-server toepassingen etc.) die ik met een set-up "andersom" (de Synology router eerst) op precies dezelfde wijze zou moeten uitvoeren.
Met in mijn geval met die laatste set-up zelfs een minder goede anonimiteit op het web m.b.t. veiligheidsaspecten. (Ik zit niet te wachten op bezoekers en hack-pogingen vanuit Rusland, Azië e.d.).

Een set-up "andersom" (met nog steeds de Experia Box erbij) is IMO dan lood om oud ijzer. En al helemaal onnodig als ik daar ook nog eens een extra managed switch voor zou moeten aanschaffen om datgene aan netwerk-services voor elkaar te krijgen wat ik nu ook al heb.

Je realiseert je die mogelijkheden wel voldoende?

Als mensen een bepaalde set-up uit hobby-overwegingen doen.
"Niet omdat het moet, maar omdat het kan", vind ik dat overigens een prima reden hoor. :)
Maar dat argument heb ik nog niet gehoord.
Reputatie 8
Voor degene die servers, VPN etc. gewoon willen gebruiken van buiten uit, met eerst de Experia Box, en daarachter een 2e router, heb ik op het Synology forum een beschrijving met aanvullende plaatjes, gewoon NAT achter NAT. Ik denk als mensen dat doornemen, het principe goed is te begrijpen.
http://www.synology-forum.nl/synology-router/vpn-verbinding-met-rt1900ac-als-vpn-server/msg173632/#msg173632

De instellingen in dat voorbeeld zijn gedaan voor alle VPN protocollen, web-server op de NAS, en connectie "rechtstreeks" met de achterliggende gebruiksinterface van de NAS (m.b.t bestandsbeheer), en Synology router met eveneens "mini"-achtige NAS-functionaliteiten. Het principe geldt natuurlijk voor elke andere service die je achterliggend wilt gebruiken.

Met name de faciliteiten van de Synology router heb ik al eens ingezet bij gastlessen op een school, waarbij leerlingen klassikaal hun resultaten rechtstreeks hebben ge-upload (35 tegelijk ingelogd) zonder problemen, naar in dat geval een share op een erachter hangende USB-disk.

Ten aanzien van beveiliging, en een typisch trucje wat werkt als je NAT achter NAT gebruikt, zie volgende reactie, en eerdere vraagstelling:
http://www.synology-forum.nl/synology-router/hoe-complete-stealth-mode-bekomen/msg175726/#msg175726

Als mensen nog geïnteresseerd zijn m.b.t NL-domein, certificaten en "re-directs" vanuit sub-domein (doorverwijzingen) kan ik nog wel wat meer hyperlinks geven waarin dat is uitgelegd.
Reputatie 8
Badge +19
Ik ben helaas niet bekend met alle functionaliteiten van deze Netgear.
Ik lees wel vaak dat het met de juiste losse switch (unmanaged, maar wel de mogelijkheid tot IGMP-snooping) wel succesvol werkt.
Voor meer expertise hierover zal je op mogelijke andere reacties van forumleden moeten wachten, we hebben er hier een paar die hierover wel alles weten... 😉
Reputatie 8
Heb van de R6400 de gebruiksaanwijzing gedownload en gekeken wat de mogelijkheden zijn:
Te downloaden bij Netgear < als PDF-bestand >
Tevens ook bij een website van gebruiksaanwijzingen:
https://www.manualslib.com/download/977556/Netgear-R6400.html

De Netgear lijkt vergelijkbare beperkingen te hebben qua instelmogelijkheden (geen separate "tagged"en "untagged" opties) zoals een Asus-router hier eerder in de draad al diverse keren voorbij gekomen. Toch heeft een van de laatste gebruikers daarmee een werkende set-up weten te realiseren.
Dus misschien dat je met vergelijkbare instellingen daarmee ook het zaakje werkend krijgt?

Met name om TV aan de gang te krijgen, de instellingen zoals aangegeven < HIER >

Je zou dan de volgende stappen kunnen nemen.
Eerst de basis WAN ingang instellingen om Telfort signaal in de router binnen te laten komen.
Blz. 24 van de handleiding.
- Geen login (en wachtwoord) benodigd.
- Account en domeinnaam laat je leeg.
- Voor internet IP-adres: Automatisch dynamisch IP-adres van de ISP
- Voor DNS-server IP adressen zou ik die van Telfort NIET gebruiken. Die blijken geregeld onbetrouwbaar.
Vul daar bijv. in voor:
1e DNS ---- die van Open DNS = 208.67.222.222 ---- (of 208.67.220.220)
2e DNS ---- eentje van Google = 8.8.8.8 ---- (of 8.8.4.4)

Tot zover dit gedeelte.
(MAC-adres zou ik in eerste instantie NIET overnemen van de Experia Box).

Dan specifieke VLAN-instellingen voor de LAN (en WLAN) uitgangen, blz. 42 halverwege, en verder op blz. 43, 44
- Vinkje bij "Enable VLAN / Bridge setup"
- En het rondje aanvinken iets verder naar beneden "By VLAN Tag group"
- Dan geef je elke poort een VLAN ID
LAN-poorten 1, 2 en 3 VLAN ID 34
Priority ----> glasvezel is zodanig snel dat je daar weinig verschil merkt wat je gebruikt.
Zelf (met een Synology RT1900ac router rechtstreeks achter glasvezel) heb ik die gewoon op 0 staan.
Het gaat alleen om de afhandeling welke data een voorkeur zou kunnen hebben. (Bijv. Telefoon boven internet).

Voor LAN-poort 4 zou je kunnen kijken of je daar VLAN ID 4 voor kunt gebruiken om de TV-ontvanger aan te sluiten.
Lukt het daarmee niet, zoals eerder bij de Asus-gebruiker, vul je ook daar VLAN ID 34 in.
(Ter referentie: Ook bij een Experia Box, ondanks TV met VLAN ID 4 is de TV-ontvanger zelf in het fysieke sub-net van de andere apparaten binnen het LAN netwerk opgenomen = VLAN ID 34. Alleen TV kun je niet ontvangen op dat netwerk, maar loopt "binnen een tunnel" door naar de TV-ontvanger waar in de TV-ontvanger het VLAN ID 4 wordt opgepakt. Vergelijk het met een soort van "VPN").

Voor WiFi op beide banden (2.4 en 5 GHz) gebruik je VLAN ID 34

Router herstarten en kijken of je in ieder geval een WAN IP-adress krijgt toegewezen.
Dat kan tot 10 minuten duren, afhankelijk in welke "leverstraat" je bent ingedeeld (WB-A of SNI-F).
Kijk dan of je internet hebt op de LAN-poorten 1,2 en 3. En op LAN poort 4 een TV-ontvanger, en of je dan TV krijgt.

Laat je weten of dat iets oplevert?
Reputatie 1
Zo... ik heb het werkend.

Mijn configuratie is als volgt:
Mikrotik direct aangesloten op NTU (met UTP kabel op ether 1)
Er loopt een kabel van Ether2 naar de decoder (IPTV)
Er loopt een kabel van Ether3 naar de Experiabox
Uit de rest van de poorten komt gewoon internet... (voor bijvoorbeeld laptop)

Ik heb de volgende export (wat aangepast omdat er gegevens van mij in stonden)
code:
# feb/02/2016 23:08:00 by RouterOS 6.33.5
# software id = KH2J-2QLJ
#
/interface bridge
add name=bridge-internet
add name=bridge-iptv
add name=bridge-voip

/interface ethernet
set [ find default-name=ether1 ] comment=WAN
set [ find default-name=ether3 ] comment=Experiabox

/interface vlan
add comment="Internet + VoIP" interface=ether1 name=vlan1.34 vlan-id=34
add comment="IPTV" interface=ether1 name=vlan1.4 vlan-id=4
add interface=ether3 name=vlan3.34 vlan-id=34

/ip pool
add name=DHCP-POOL ranges=10.1.10.40-10.1.10.254

/ip dhcp-server
add address-pool=DHCP-POOL disabled=no interface=bridge-internet lease-time=\
3d10m name=DHCP

/interface bridge port
add bridge=bridge-internet interface=wlan1
add bridge=bridge-iptv interface=ether2
add bridge=bridge-internet interface=ether8
add bridge=bridge-internet interface=ether9
add bridge=bridge-internet interface=ether4
add bridge=bridge-internet interface=ether5
add bridge=bridge-internet interface=ether6
add bridge=bridge-internet interface=ether7
add bridge=bridge-iptv interface=vlan1.4
add bridge=bridge-internet interface=ether10
add bridge=bridge-voip interface=vlan1.34
add bridge=bridge-voip interface=vlan3.34

/ip address
add address=10.1.10.1/24 interface=bridge-internet network=10.1.10.0

/ip dhcp-client
add default-route-distance=0 dhcp-options=hostname,clientid disabled=no \
interface=vlan1.34

/ip dhcp-server network
add address=10.1.10.0/24 dns-server=10.1.10.1 gateway=10.1.10.1

/ip dns
set allow-remote-requests=yes servers=8.8.8.8,8.8.4.4

/ip firewall address-list
add address=10.1.10.0/24 list=OurLocalLan

/ip firewall filter
add chain=input comment=\
"Allow access to the router from the LAN using address list" \
src-address-list=OurLocalLan
add chain=input comment="Allow established connections to the router" \
connection-state=established
add chain=input comment="Allow related connections to the router" \
connection-state=related
add action=drop chain=input comment="Drop all other trafic to the router"
add action=drop chain=forward comment="Drop invalid connections" \
connection-state=invalid
add chain=forward comment="Allow connections from the LAN" connection-state=\
new in-interface=bridge-internet
add chain=forward comment="Allow established connections" connection-state=\
established
add chain=forward comment="Allow related connections" connection-state=\
related
add action=drop chain=forward comment="Drop all other trafic to the router"

/ip firewall nat
add action=masquerade chain=srcnat out-interface=bridge-internet \
to-addresses=0.0.0.0
add action=masquerade chain=srcnat out-interface=bridge-iptv to-addresses=\
0.0.0.0
add action=masquerade chain=srcnat out-interface=bridge-voip to-addresses=\
0.0.0.0


Het enige waar ik benieuwd naar ben is of telfort het gaat pikken dat ik nu eigenlijk 2 routers op internet heb aangesloten (want ik krijg in mijn experiabox een WAN ip van telfort. Wat ik het liefst zou willen is dat de ip van de experiabox een LAN ip-adres wordt.

Uiteindelijk zou ik graag de experiabox willen vervangen door een SIP-telefoon waarmee ik dan m'n voip kan afhandelen.
Er is dus nog wel wat werk te doen.

Ik trek wel m'n volledige snelheid.

Reputatie 1
Ik ben zelf ook aan het kijken om de Experiabox te vervangen. Voor zover ik het nu kan zien loopt tv over VLAN4 en internet over VLAN34. Waar bij KPN voice over een apart VLAN loopt (VLAN7) lijkt dat bij Telfort niet het geval te zijn, maar wordt die over de gewone internet verbinding gelegd.

De optie incl. telefonie zoals ik 'm nu zie zou zijn:
- Eigen router aan glasvezelmodem.
- VLAN34 met DHCP op router afhandelen
- Vervolgens VLAN7 en een intern VLAN34 doorsturen via een TRUNK naar de Experiabox die achter de router hangt.
- TV's en telefoon via Experiabox laten lopen.

De vraag is alleen hoe veeleisend die experiabox is. Kan me sowieso voorstellen dat je voor telefonie wat poorten zal moeten openzetten in je eigen router.
Ik hoop komend weekend wat tijd te hebben om e.e.a. uit te zoeken.
Reputatie 8
Ik denk niet dat het zo gaat werken.
Omdat de poorten van de Asus "beneden" de signalen zijn gescheiden apart voor internet en TV, splits zich dat niet opnieuw, alsof het boven "bij elkaar" als signaal aangeboden wordt.

Wil je boven zowel internet (voor verdere distributie via WiFi) alsook TV, zul je die twee signalen "apart" moeten doorsturen. Ofwel nog een extra kabel erbij moeten trekken, zodat je twee lijntjes hebt boven.
Als dat bezwaarlijk is, zou je misschien alleen voor de TV een Powerline kunnen gebruiken, en gebruik je de kabel die er nu ligt naar boven voor internet? Boven zou ik dan alsnog een "eenvoudig" WiFi Access Point neerzetten (koppelen aan de "internet" netwerkkabel). Een 2e Asus RT-AC68U in AP mode lijkt me te kostbaar.
Reputatie 1
Ik snap niet helemaal hoe je setup is waar je een conf file voor wil. Kan je dat wat meer omschrijven?
Reputatie 8
Badge +16
Ik heb glasvezel inderdaad en zag een tutorial over hoe je gegevens te vinden. Dat komt goed.
Maar ik wil eerst m'n nieuw mikrotik aan de praat krijgen met de experiabox er achter. Zoals Peetman.

Hoe kan je je SIP gegevens vinden? Waar heb je dat gelezen? Ik ben heel benieuwd. Laat je bron even weten.


Zoeken in het glasvezel gedeelte van het forum misschien....?
Vandaag eindelijk wat tijd gehad de config nog eens onder de loep te nemen. En het is gelukt. Ik heb nu de situatie zoals ik die graag zou willen hebben, dus zonder de Experiabox. Mijn opstelling is nu als volgt: Genexis naar managed Cisco switch (tagged VLAN 4 & 34) en van managed switch naar Fortigate (untagged VLAN 34). Na 10 minuten nog steeds geen IP adres op de Fortigate gekregen. Daarna de Genexis, switch en Fortigate gereboot. Nog steeds niets. Vervolgens de config van de trunked port op Cisco switch aangepast en daar de Layer 2 protocollen CDP en LLDP uitgezet en spanning-tree in zijn geheel uitgezet (stond op Spanning-tree port-fast voor die interface). En na meer dan een uur zag ik op de sniffer heel veel verkeer voorbij komen en zag ik op de WAN1 interface van de Fortigate het externe IP adres verschijnen. Direct een ping opgezet naar 8.8.8.8 en alles zag er goed uit. Een tijdje laten lopen, vervolgens alles nog een keer een reboot gegeven, om te kijken dat het niet eenmalig was, maar direct zag ik weer het IP adres op de WAN interface staan. M.a.w. eindelijk werkt het. Bedankt voor de tips hiero.
Ik heb nu uiteindelijk LAN 1 en 2 als internet poorten voor NAS en PC en heb besloten te kunnen leven zonder telefonie. De Experiabox ligt nu in de kast. TV's op LAN 3 en 4 en alles lijkt te werken. Ik zie alleen de log's van mijn Asus vollopen met de volgende melding (zo'n 4 per minuut):

58 kernel: Dead loop on virtual device vlan34, fix it urgently!

Weet iemand wat ik verkeerd doe?


Ik heb eigenlijk opgegeven om de experiabox te vervangen of achter de asus router te zetten, dit vanwege de telefoon.

Ik heb nu een configuratie waarbij de asus router achter de experiabox zit, de telefoon zit ook aan de experia box terwijl de TV's achter de asus router staan. Tijd moet nog uitwijzen dat hiermee het bevriezen van het tv beeld wordt voorkomen.

Dit is mijn asus configuratie:



Wellicht kun je deze configuratie uitproberen ipv Manual. In mijn system log komen geen abnormale foutmeldingen. Als het niet werkt heb ik geen andere suggesties voor je.
Dank voor de suggestie. Ik heb de router een paar dagen geleden gereboot en zag dat er een VLAN setting was teruggesprongen. Deze heb ik weer goed gezet en nu geen foutmeldingen meer. Ik heb het ISP profiel op manual laten staan, maar hoe "None" ook in gedachten voor als het weer mis gaat.
Reputatie 1
Http://teusensimone.nl/ict/telfort/telfort-sip-getest-met-glasvezel/
Reputatie 8

Heb hier echter wel de Experia Box in het LAN subnet van de Synology Router als input voor WAN.

Excuses voor de andere lezers. Nog eens verder en dieper de achterliggende gegevens bekeken, maar eerder iets te snel met die conclusie gekomen.

Bij de set-up van eerst de Synology router achter de glasvezel, en achter de ingestelde LAN-poort t.b.v. VOIP van die router, daarachter de Experia Box:
Ook bij mij wordt achterliggend in de Experai Box zelf nog steeds het "oude" WAN IP adres gebruikt, wat hetzelfde is als men de Experia Box rechtstreeks aan de glasvezel zou hangen.

Dus men heeft een "nieuw" WAN IP-adres voor de 1e eigen router.
De Experia Box, die als 2e router achter de eigen 1e router hangt, intern het "oude" WAN IP adres.

Verder de instellingen voor de Synology router:



In mijn geval heb ik (nog) geen prioriteiten ingesteld als voorkeur wat voorrang heeft bij meerdere data-stromen. (Dat lijkt me bij een 100/100 Mbps verbinding ook niet echt relevant).
Anders zou men voor telefoon (VOIP) = 1 kunnen instellen, en voor IP-TV = 2


Dat is het voor wat betreft de Synology router voor wat betreft instellen als 1e router achter glasvezel.

Op dit moment zitten er IMO nog wel nadelen in het gebruik van de Synology Router als 1e router direct achter het internet, die NIET naar boven komen als men gewoon de Experia Box als 1e modem/router aanhoudt (en dan de Synology als 2e router).

Dat heeft te maken met de werking van de Firewall van de Synology router t.b.v. connectie van buitenaf naar binnen. (Men wil inloggen op een NAS, om data op te pikken).

Op dit moment hebben "Port Forwarders" naar apparaten prioriteit, bóven de Firewall.
Ofwel poortverwijzingen gaan vóór de Firewall uit. Dat houdt praktisch in, dat de Firewall van de Synology router genegeerd wordt als men data naar achterliggende apparaten doorstuurt. Men zal dan in het achterliggende apparaat zelf een erg goede Firewall moeten gebruiken.
Nu heb op de erachter hangende NAS (Synology) wel een erg goede Firewall.

Als de NAS "aanstaat" (ingeschakeld) werkt alles prima.
De Firewall in zowel de router als in de NAS heb ik ingesteld als zijnde:
"toenadering mogelijk alleen vanuit de regio Nederland".
(Dat zijn opties bij Synology om Firewalls per regio in te stellen die toegang mogen hebben).

Als er dan connectie wordt gelegd ergens van BUITEN Nederland naar mij, is mijn verbinding "onzichtbaar".
Alsof ik niet besta!! Precies wat de bedoeling is in mijn opzet, ondanks dat web-servers, bestand-service en VPN-verbindingen als toenadering vanuit Nederland wel mogelijk zijn:

Test via "Shields Up" waarbij ik expliciet op de poorten heb gescand die vanuit Nederland "open" staan:
https://www.grc.com/shieldsup
(Shields up zit namelijk zelf in Amerika = buiten Nederland).



Staat de NAS UIT (niet ingeschakeld) voordat de router actief was, krijg ik deze melding:



Nu kan ik de services nog steeds niet benaderen die op de NAS gebruikt worden, omdat de NAS uit staat. Maar ik wordt wel als zodanig opgemerkt.

De andere poorten betreffen de services op de Synology router zelf. (Daar zijn geen port forwarders voor ingesteld, want men zit al op de router, en werkt de Firewall voor die services wel gewoon).

De Experia Box als 1e router aangesloten, en de Synology router als 2e, geeft ALTIJD een "Steath", ondanks een erachter hangende NAS is uitgeschakeld. Poorten die in de Experia Box zijn doorgestuurd, maar niet benut omdat er geen apparaten daarvoor ingeschakeld zijn, worden als "niet open", niet ingeschakeld bestaande poorten beschouwd. Dus zo gek is die Experia Box eigenlijk niet (op dat punt).



Tot zover de informatie, groet Babylonia@
Klopt, ik heb nog een android box staan (voor sporadisch gebruik) en dat werkt wel maar via de TV-box is zo lekker makkelijk...
Telfort klantenservice heeft net gereageerd:
---
Fijn te lezen dat u weer tv kunt kijken via het eigen modem.
Ik heb geïnformeerd betreft het Meer tv. Dat hoort inderdaad bij een software update en deze worden normaal gesproken automatisch s ’nachts gedownload. Er is naar ons kennis geen mogelijkheid om de software handmatig te downloaden.
Het advies is als het niet automatisch gebeurd dat u dan tijdelijk ons modem aansluit totdat de software geïnstalleerd is
---
Hmmm..dus toch de experia er weer even aan?? Ik vraag mij af of dat werkt...ze zeggen iig niet dat het niet meer mogelijk is met een eigen modem...ik ga nog maar een keer een poging doen deze week...
Badge
Bedankt. Ik ben een tijdje niet meer op het forum actief geweest, had de hoop eigenlijk opgegeven. Goed dat deze informatie uitgezocht en gedeeld wordt.
Ik had deze uitleg net ook gezien: http://blog.ritmeester.co.nl/2015/11/achterhalen-telefonie-gegevens-telfort.html (lijkt alleen wat omslachtig).
Badge
Ja, dit tekort geldt voor alle poorten. Zie screenshot.



LAN 1+2 worden gemeenschappelijk geconfigureerd, LAN 3 en LAN 4 separaat.
Ik had gehoopt alternatieve Asus firmware te kunnen installeren zodat er meer opties te voor schijn komen in de GUI echter is het voor mijn router RT-N18U niet geschikt. Die is er in de vorm van asuswrt-merlin.

Ik schuw CLI niet, heb ik ook tijdens gedaan met mijn vorige n-router van TPLink met dd-wrt erop.
Reputatie 8
Bij jou Asus wordt ook een scheidng gemaakt voor internet op poort 1 en 2.
De rest in te stellen op die andere poorten. Ik ga er even vanuit dat de settings die je toont voor de poorten 3 en 4 dan eigenlijk als "tagged" gezien moeten worden.

Omdat je op dit moment volgens mij toch de Experia Box achter de Asus hebt gehangen voor telefonie, waarvoor een "tagged" instelling geldt, om het te kunnen doorgeven. Zou je kunnen kijken of je met tevens VLAN ID 4 erbij te zetten, bij bijv. poort 3, of je Experia box dan tevens ook weer voor IP-TV is te gebruiken.
Je gebruikt de Asus dan aleen als eerste router, en doorgeefluik voor VOIP en IP-TV op de Experia Box.

De schrijfwijze in jouw plaatje zou dan voor een VID moeten zijn:
VID 34, 4
of
VID 4, 34

Ik weet niet of dat wordt gepikt door je Asus. Maar je kunt het proberen.

Bij mijn eerdere testen viel het me namelijk op, dat als ik de Experia box achter poort 3 had hangen (in mijn geval "tagged"), het lampje van "Voice" op de Exeperia Box brandde, en dan de telefoon via de Experia Box werkt.

De Experia Box aangesloten op poort 4 van de 1e router (met VLAN ID 4), brandde alleen het groene TV-lampje.

Het is dan niet de situatie die je eigenlijk wilt (twee routers achter elkaar), maar het geeft je wel meer inzicht in wat er eigenlijk gebeurt met de data-stromen.

Eigenlijk met hetzelfde idee was mijn insteek, om die VID 4 meteen voor de poorten 1 en 2 als zodanig te proberen. Dus voor poort 1 en 2

VID 34, 4
of
VID 4, 34

en dan meteen kijken of je de TV set-up box achter poort 1 of 2 kunt inzetten.


1. Experiabox afkoppelen, terug in de doos, weg ermee.
2. Stel de router in op DHCP op de WAN zijde.
3. Ga op de router naar LAN > IPTV.

Select ISP Profile: Manual
Internet: VID 34 PRIO 0
LAN port 4: VID 4 PRIO 0
LAN port 3: VID 4 PRIO 0

4. Sla de config op en reboot je router
5. Sluit op de NT box rechtstreeks een netwerkkabel aan op de WAN poort van de router.
6. Sluit je PC's aan op poort 1. In mijn geval een unmanaged gigabit switch gebruikt voor verdeling
7. Sluit de TV IPTV boxen aan op poort 3 en 4


Bijna goed! (ik heb toevallig ook een ASUS)
Poort 4 heb ik ingesteld als VID 4 PRIO 0, zodat daar TV op gezet kan worden. Poort 3 is echter VID 34 PRIO 0, en dan kun je daar de Experiabox aan hangen voor telefonie.

Verder niets doen - even wachten tot je router een IP krijgt en klaar. Geen MAC clone, geen inloggegevens, gewoon helemaal niets. Enkel die drie VID instellingen neerzetten en klaar.[/quote]

Helaas, werkt niet bij mij.
TV doet het prima via mijn asus, doch telefoon doet het niet via de experia box.

Op poort 1 en 2 geeft mijn Asus router een IP adres aan mijn laptop, doch de Experia box aangesloten op een van deze poorten geeft in de log de volgende foutmelding:

03/23/2015 00:01:55 DHCP Client: [ths]Could not find DHCP daemon to get information
03/23/2015 00:01:52 DHCP Client: [ths]Send Discover
03/23/2015 00:01:49 DHCP Client: [ths]Send Discover

Mijn Asus router ziet de experia box ook niet als DHCP client als die is aangesloten op poort 1 en 2.
Voice status op de experia box geeft Fail aan.
Reputatie 8
Je geeft (gelukkig) nu nog wat extra info hoe je het een en ander toch aan de gang hebt gekregen, (wat mij zelf nu nog niet helemaal duidelijk is).
Maar in ieder geval goed te horen dat het nu functioneert.
Deze informatie komt beslist een keer van pas bij andere vergelijkbare set-ups.
Dank voor het delen van die informatie.
Reputatie 8
Die twee methodes heb ik ook bekeken en toevallig een uurtje of wat geleden met de eerste methode aan de gang gegaan.

< Foefje één > en < Foefje twee > (wat omslachtiger IMO) om SIP-gegevens Telfort te achterhalen.

....en Met succes !!
Maar heb het voor de goede orde nog iets aangepast, aan persoonlijke werkwijze en omdat ik de beschrijving op enkele punten toch niet helemaal duidelijk vond. Zelf ontkoppel ik de WAN netwerkkabel overigens niet. Dan loopt alles wel wat vlotter door, maar inladen VOIP gegevens zijn toch pas zo'n beetje de laatste stap wat als data doorloopt.

Kort samengevat wat je nodig hebt:

“WireShark” om de logbestanden makkelijker te analyseren:
http://www.wireshark.org

(Zelf gebruik ik een oudere portable versie, omdat die compacter is)
Oudere versies WireShark (onder Win + OSX) te downloaden
https://www.wireshark.org/download/

Om WireShark te draaien heb je mogelijk ook “WinPcap” nodig.
http://www.winpcap.org/

Zelf doe ik alle benodigde stappen “vanachter de PC”.

Fabriek-reset modem/router: (procedure geldt dus voor de Experia Box V8 )
Mocht je persoonlijke aanpassingen hebben gemaakt in de modem, dan eerst back-up van instellingen.
- inloggen modem via webbrowser: 192.168.2.254
- horizontale menu bovenaan: EXTRAS
- verticale menu links: Backup / Restore
- scherm rechts bovenaan: Backup Configuration of Router - maak backup van de configuratie
- RESET = Meteen daaronder op hetzelfde scherm: Restore to Factory Defaults

Meteen na de reset opnieuw inloggen, en alles nu vrij vlot achter elkaar doorvoeren.
Je hebt wel even hoor, maar de volgende stappen moeten worden gestart nog voordat de telefoon/VOIP gegevens opnieuw in de modem zijn geladen (circa 2 minuten ?).
- wachtwoord is gereset naar 1234 – maak nieuw wachtwoord aan.

- horizontale menu bovenaan: EXTRAS
- verticale menu links onderaan: Diagnostic
- op scherm rechts: Diagnostic Utility ---> bovenste optie
WAN Packet Capture ----> Target Interface ---> WAN 1 ---> druk meteen op de Start-knop

- Schermpje om bestand op te slaan volgt, en sla bestand “pktDum.cap” op.
Dit is een actief “open” bestand wat met gegevens wordt aangevuld zolang de actie niet wordt gestopt.

- Houdt de Experia Box modem in de gaten totdat het groene lampje van “Voice” brandt.
Gegevens van telefonie zijn dan in de modem ingeladen en in de “pktDum.cap” vastgelegd.
- STOP nu de vastlegging bij Diagnostic Utility - WAN Packet Capture
----> Target Interface ---> WAN 1 ---> druk op STOP.

Inlezen gegevens in WireShark
- Start WireShark op en laadt het “pktDum.cap” bestand in.
- Doe een zoekactie als string-mode (anders werkt het niet) met de zoekcriteria “register sip”.

Bij de bovenste indeling / scherm van WireShark vind je dan twee regels:
REGISTER sip:tel.telefoniedienst.nl:5060

Als je die regel aanklikt, vind je in het middelste scherm onderste optie:
“Session Initiation Protocol (REGISTER)”

Klap het plusje open (+), en je krijgt alle relevante SIP-gegevens, waaronder o.a. het “Call-ID”.
Als je op WAN2 klikt dan zie je VLAN 7 echter zonder WAN protocol:

Edit: bijlages verwijderd aangezien er IP-adressen in stonden.
Badge
Helaas kan je maar één nummer bij elke VID invullen. Comma seperated gaat niet. Toch lees ik in deze reactie van Mr.Nicorp dat het moet werken. Zou hij het echt hebben werken? Mr.Nicorp? Hoe zit het met tagged/untagged instellingen in de Asus software?
Reputatie 8
Overigens in het rijtje van te gebruiken routers "in plaats van" de Experia Box (of een andere door een ISP geleverde modem/router) kan de vrij jonge Synology RT1900ac waarschijnlijk ook worden toegevoegd.

Met een firmware update die men ruim 14 dagen terug heeft doorgevoerd, zijn IP-TV en VOIP functies toegevoegd.
Omdat de router geen RJ11 poortjes voor telefoon heeft en geen uitvoerige inlogschermen om SIP-gegevens in te vullen, --het is in dat geval zuiver een "doorgeef-luik" voor VOIP--, zul je voor het gebruik van telefoon, wel een extra VOIP centrale moeten aankoppelen waarbinnen je alle gegevens vastlegt.

Een eerste gebruiker meldt een werkende set-up voor XS4All (had geen abonnement op telefoon en TV).
Zelf heb ik wel wat geëxperimenteerd, met instellingen "op de bonnefooi" (wist niet welke gegevens in te voeren) waarbij geen gebruik van telefoon (ik heb geen VOIP-centrale), en kwam wel tot een werkend internet, maar nog geen resultaat voor IP-TV.

Voor geïnteresseerden, wacht eerst verdere gebruikerservaringen af.
Badge
Helaas, werkt niet bij mij.
TV doet het prima via mijn asus, doch telefoon doet het niet via de experia box.

Op poort 1 en 2 geeft mijn Asus router een IP adres aan mijn laptop, doch de Experia box aangesloten op een van deze poorten geeft in de log de volgende foutmelding:

03/23/2015 00:01:55 DHCP Client: [ths]Could not find DHCP daemon to get information
03/23/2015 00:01:52 DHCP Client: [ths]Send Discover
03/23/2015 00:01:49 DHCP Client: [ths]Send Discover

Mijn Asus router ziet de experia box ook niet als DHCP client als die is aangesloten op poort 1 en 2.
Voice status op de experia box geeft Fail aan.

Kan je een screenshot maken van je IPTV instellingen binnen de Asus software?

Reageer